Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,279
Community Members
 
Community Events
176
Community Groups

User does not exist error when importing CSV File (External System Import)

This is for the Cloud version of JIRA Software.

I am trying to bulk create-and-assign using the CSV import function. My CSV file contains the assignee in username format. I did not check the 'map field value' as suggested by https://confluence.atlassian.com/jirasoftwarecloud/creating-issues-using-the-csv-importer-764478441.html#CreatingissuesusingtheCSVimporter-RunningtheCSVfileimportwizard . I still cant create the tasks. I always get the error :

  • Issue can't be created due to the error/s [ User 'redacted' does not exist. ]

The user 'redacted' has been added to the project with the Developer role, and yet this issue happens. I tried to change from username to the actual user name in "Firstname Lastname" format, no luck. 

 

Any ideas? 

4 answers

I am also having this issue. This is the first time since doing this monthly for a year. Something on Jira's end must have changed.

When I use the @Graham to see my user ID I see this:

[Graham O'Bray|~accountid:5b3149d263379b3ac420d300]

My user ID = gobray (which is what I always used to reference when I did my prior bulk load froM CSV)

I tried using the account ID with no success....any ideas?

 

Thanks,

Graham

I run into same problem, and was able to (kind of) deal with it.

It turned out that user name, shown in Jira, even on user profile page, doesn't actually match internal user code. But when you try to mention user in a comment, it resolves to correct code.

 

For example, I have a user with name John D, and it shows alias @JohnD on his page. When I try to import issues with assignee `johnd` - it fails.

When I enter comment, `@johnd` is replaced with [~jdoe] 

I try to import issues with assignee `jdoe` - it works like a charm.

 

And there is no other place in Jira, where I could find this actual user code.

I didnt find a solution for this.

Finally imported 100+ tasks manually without any assignee.

To ease this, what I did was to create a separate CSV per user, import it without assignee, bulk select the group and assign to the same user. This way I didnt have to do 100+ assignments, just a few. 

0 votes
jira guy Rising Star Feb 27, 2018

adding the user as username should work without any errors while importing data through CSV. Firstname Lastname format is not supported while importing assignee.

Check to see if the user is active and exists in JIRA. Check the permissions to see if developer is assignable user.

thanks for the reply. 

adding the user as username doesnt work. I get the same user 'username' not found error. 

user is active, exists in JIRA, and has the developer permission. I am able to edit an existing issue and assign to this user. Note that I am having this problem with 5 different users. 4 of them are new to JIRA cloud, added recently, but 1 of them has already used multiple JIRA cloud projects. 

is there a hidden requirement for the users to login to the project at least once before they are 'discoverable' for the csv import tool? i plan to try that later today. If that doesnt work, i will just import my 100+ tasks without any assignee and then assign them manually :(

Like it.helsinki: JIRA Admin likes this

I am having the same Issue - testing importing CSV to cloud -

I can assign 2 of my users but cannot seem to assign a third

The User I am having issues with is an admin user (as am i)

I use their jira ID and also tried their email address... no luck ... I have 500+ issues to import ... need to be able to do this...

I am also facing this same issue. We triple checked that all user id exist also relevant privilege is given to those ids in Permission scheme, still I am not to upload data. 

As per the suggestion given in another discussion thread, I removed the email id (which suppose to be the user id) and gave the only the user id without domain name. 

Ex:- if my user id is tom@domain.com, I gave only tom. I removed @domain.com. It imported properly.

Like # people like this

Worked for me! thanks!

Nice. This worked for me too i.e. replacing homer.simpson@cartoon.com / "Homer S" with "homer.simpson" in the CSV file.

 

I've given up trying to bulk update and Move issues from next-gen to classic project types due to many other problems, so CSV exports/ imports will suffice for the moment. 

Like Prasad Kawadkar likes this

The "homer.simpson" solution worked for me as well.

Thanks. :)

Tried importing issues as of now. Had the same struggles as the rest of the people in this tread.

But it worked when i set the user id to this format "name@domain.com". 

Alternative solution: 

When you export issues with Assignee + Assignee Id you'll get 

 

AssigneeAssignee Id
maike.wagner5c658d858181d3640803d417

 

When importing map "Assignee Id" to field Assignee

image.png

Like Magdalena Zhisheva likes this

 We have a limited user capacity on our license & need to import projects from other instances but their users will not be joining:  Do these solutions create users? 

As posted by @Jürgen Richter after couple of tests on our side I was able to solve this as during the map I perform the User ID CSV column to the actual user Jira Field, i.e. 

Assignee ID -> Assignee

Reporter ID -> Reporter

Watcher ID -> Watchers 

It also works for each custom Jira fields which are containing user list. Works every time for us!

Hope it will help someone!

Best Regards,

Magdalena Zhisheva

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events