Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to use new team member's name in assignee field

I've been using Jira since February, but haven't needed to add anyone new until now. I've added the new person to my account and also to the project. However, when I validate the CSV file before doing a bulk upload I get an error saying issues can't be created because [User 'her name' does not exist]. If I go into an existing issue, I'm able to select her name from the Assignee dropdown list. 

I've checked every permission scheme, etc. but can't figure out why her issues are creating this error. 

2 answers

1 accepted

1 vote
Answer accepted

I just received a response from Gino at Atlassian Support.  Here's what he said: 

"New users need to use the Atlassian ID or email in the CSV file, this is because of the GDPR compliance and we have this document with more information about why we are no longer using user names."

I wish I'd known this before I spent several hours trying to figure out what was wrong. Hoping this saves someone else some time and frustration. 

Yes I feel your pain.  It was a rubbish idea, to do this as now JIRA does not let me search for available users when to change the Reporter - neither accept any name tat I type manually.

0 votes
John Funk Community Leader Dec 16, 2020

Hey Shelley,

As a quick fix, I would just upload the issues with your name. Then once those issues are created, do a Bulk change and Edit the issues to update with the new user name. 

That's what I'm doing, but it's not going to a viable solution for long as this individual will soon have many cards that need to be uploaded. 

John Funk Community Leader Dec 16, 2020

Just curious but why is all of this work being done in spreadsheets and not directly created in Jira? 

We're a consulting company that works with nonprofits and are using Scrum with our grant writing team. The projects all break down into very similar parts, so we have "standard" stories (issues in Jira language) for each project. Each story gets scored by the team using agile poker based on the complexity of the specific project, but each project works through the same basic process to completion.

In 2020, we worked 180+ projects with more than 4,000 stories/issues. Excel allows us to (1) efficiently create the correct stories/issues for each project through a semi-automated process, and (2) serves as our master project calendar. Approximately every 2 weeks, prior to the start of a sprint, we create a batch of stories/issues which are then uploaded in bulk to Jira so they can be pulled into the next one or two sprints. 

John Funk Community Leader Dec 17, 2020

Okay, but I still don't see why you don't just create the issue in Jira instead of adding it to a spreadsheet. You can export/download the list of issues from Jira if you want/need to look at them in a spreadsheet for some reason. 

You are still typing in all of the data, whether it is is an spreadsheet or a Jira issue. 

Regardless of the soapboxing on my part  :-)  why will the option I suggested not work? 

Just upload all of the issues from Excel to Jira to create the issues, then do a Bulk change to update the Assignee. 

It's impossible for me to explain why this would be a horribly inefficient process for us in this venue. 

I'd really love some help resolving my original problem. I've been using this process for 10 months with no problem, but now I'm getting the error with a new member of our team. I've checked everything--to me, it looks like she's set up with all of the same permissions as everyone else on the team. I've looked through every single setting and can't figure out why this is happening. I've spent HOURS trying to figure out what's wrong. Unless I can get some help, any additional time I invest will be in finding something to replace Jira. 

John Funk Community Leader Dec 17, 2020

Fair enough. Is it only with this one user that you are having the problem? Can you upload with other users? 

Does the user have Assignable User permissions in the Permission Scheme for this Project? 

Yes, just one user--the most recently added person. She is in the project role of developer and that role has assignable user permission. 

If I select an issue in the project, go to permission helper and enter her name to see if she is an assignable user, Jira says she is. I'm stumped.

I've opened a ticket with Atlassian for this.

Like John Funk likes this
John Funk Community Leader Dec 17, 2020

One other test - have you tried using the account id instead of the username? Or maybe the full email address?

Just tried her email address and it works.  I don't understand why it works with username for everyone else, but at least it works.  Thanks for your help. I really appreciate it. 

John Funk Community Leader Dec 21, 2020

I have this same problem sometimes with a handful of users. I don't know what makes them different, I just know to try the email address or username if the name doesn't show up when I start typing, and I know they are valid users. 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Apps & Integrations

🍂📹 Apptoberfest demo contest roundup: vote for your favorite demos!

Hi Community! The submissions are in (and listed below) for the 🍻🍂Apptoberfest🍂🍻 Demo Competition and it’s time for you to place your votes for the best: Analytics & reporting app demo ...

120 views 2 11
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you