Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

UPM: Unexpected exception parsing XML document from URL Edited

Deleted user Jul 30, 2018

I've just upgraded to Jira (self-hosted) 7.11.1 on Linux x86_64, from version 7.3.2 and am completing the upgrade of installed plugins.


When attempting to upgrade the Atlassian Universal Plugin Manager Plugin, I get the error message:

Unexpected exception parsing XML document from URL

The logs, starting at the first 'ERROR' line with a timestamp after when I pressed the 'Update' button go as follows:

2018-07-30 16:26:15,483 ThreadPoolAsyncTaskExecutor::Thread 25 ERROR alexis 985x122x1 w835ok 130.183.2.35,192.168.1.8 /rest/plugins/1.0/ [c.a.p.osgi.factory.OsgiPlugin] Unable to start the plugin container for plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-selfupdate-plugin'
org.springframework.beans.factory.BeanDefinitionStoreException: Unexpected exception parsing XML document from URL [bundle://235.0:0/META-INF/spring/atlassian-plugins-component-imports.xml]; nested exception is java.lang.IllegalStateException: The bundle is uninstalled.
at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:414)
at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:336)
...

I've googled this, but not found anything that looked applicable. Could anybody advise? Many thanks!


Alexis

1 answer

Hi Alexis,

It sounds like you might be dealing with plugin cache corruption. Are you able to uninstall the UPM and then restart the Jira instance? Additionally, you may need to clear the plugin cache, which can be done by deleting the following directories while Jira is shutdown:

JIRA_HOME/plugins/.bundled-plugins
JIRA_HOME/plugins/.osgi-plugins

All the best,
Cameron

Deleted user Jul 30, 2018

I didn't see any obvious way to uninstall UPM (other plugins have an Uninstall button but not UPM), so I proceeded to clearing the cache, and that worked! Many thanks for the quick response Cameron!

 

Alexis

I got this same error after upgrading from 7.1.9 to 7.13.2 and this fixed the issue for me as well. Thanks

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Software

Presenting the "Best of 2020" Jira Software roundup!

Catch up with Atlassian Product Managers in our 2020 Demo Den round-up! From Advanced Roadmaps to Code in Jira to Next-Gen Workflows, check out the videos below to help up-level your work in the new ...

4,401 views 5 15
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you