Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

UI is broken due to XSRF check failed

Hi,

I'm having a problem where JIRA Server will have a broken UI (the sidebar won't load). I used the Google Chrome F12 tools and it displays that the resources and primary requests fail with 403 Forbidden, and the content body read XSRF check failed. I even disabled XSRF in the JIRA configuration and the problem persists.

One of the pages where the problem exists: https://hub.ultz.co.uk/jira/projects/SS/

It's running behind an Apache Reverse Proxy behind CloudFlare.

Any help?

2 answers

1 accepted

1 vote
Answer accepted
Andy Heinzer Atlassian Team Feb 09, 2018

Did you recently upgrade this instance?  Or is this a new installation? If this is an upgrade, could you let us know what version you upgraded from?

Even if this is not an upgrade, there are possible problems that can happen when setting up SSL and/or a proxy with Jira if you are not using the correct settings in Jira.   Since you're seeing a XSRF, that tends to happen when the traffic to the Jira Site is being redirected without the knowledge of Jira's internal tomcat instance.

Could you share with us the settings in your $JIRAINSTALL/conf/server.xml ?

Specifically I am interested to see what settings you have for the connector that is being used for the proxy traffic to reach the Jira web server.   Curious to see if you followed the guide in Integrating JIRA with Apache using SSL.

New, tried applying those settings but then the whole instance didn’t start so I switched it back. Also I’m not sure if the cloudflare proxy is gonna be a problem?

Just fixed it, turns out that it was a RAM problem that for some reason only occurred with the setttings in that article enabled. I fixed the problem and it works like a charm

Hi Dylan, I'm having a similar issue trying to create new pages in my session. What RAM problem ended up being your issue?

I have the same issue after i upgrade the Jira 7.x to 8.0.2. I am using Apache reverse proxy. I had to set: 

ProxyPreserveHost On 

 

After that everything is working fine. My proxy configuration: 


<VirtualHost *:80>
ServerName devops

ProxyRequests Off
ProxyVia Off
SSLProxyEngine On
ProxyPreserveHost On

<Proxy *>
Require all granted
</Proxy>


ProxyPass /jenkins http://localhost:8080/jenkins
ProxyPassReverse /jenkins http://localhost:8080/jenkins

ProxyPass /jira http://localhost:8087/jira
ProxyPassReverse /jira http://localhost:8087/jira

</VirtualHost>

 

Hope it helps. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Software

Presenting the "Best of 2020" Jira Software roundup!

Catch up with Atlassian Product Managers in our 2020 Demo Den round-up! From Advanced Roadmaps to Code in Jira to Next-Gen Workflows, check out the videos below to help up-level your work in the new ...

225 views 1 4
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you