Trying to use the "Link" action doesn't open any screen: there is only a small black square. Edited

Hello,

I have been having this problem at least since yesterday, and I don't know what's going on. I have upgraded to the latest version (7.4.1) from 7.3.6 but the behavior is the same.

I'm on an issue (I have tried with 3 or 4 different ones, although all on the same project), then I click on the More button, then Link. The screen goes a shade darker, and a smaller rounded black square is displayed. This same transition is visible when doing some other actions, but the small square "grows" to the input screen. This doesn't happen on the Link action.

I have cleared Chrome cache, restarted the server, used another browser (Safari, I am on a Mac), upgraded Jira, reindexed, and nothing changes.

When the small black square is displayed, if I press "Esc" then the screen returns to normal, i.e., apparently there is some input screen displayed, but with no data visible.

Here is a screenshot of said square.

Captura de pantalla 2017-07-19 a la(s) 19.06.55.png

Any ideas on how to solve this?

- Edit -

I have checked the logs on the server and I don't see anything wrong there. Also, the health-check doesn't show anything wrong with the installation.

Working around some other issues, this same problem happens from time to time with some other actions, for instance, I just clicked on the "Start progress" button and it's displaying the same behavior (even when that transition doesn't have any input screen). Clicking on the View Workflow link makes this happen also.

I'm guessing there is something misconfigured (although this was working fine before and there was no change to anything on the installation, server nor anything like that) but I just can't see what.

The problem seems to be with the use of the ISAPI redirect method, using the Tomcat Connectors/Jakarta. Accessing Jira directly on the install port (8180, for instance) works fine. I have already updated the tomcat connector to the latest available version, 1.2.42 (I was on 1.2.40) but it is still failing.

3 answers

1 accepted

1 vote
Accepted answer

Hi Rodrigo,

We did receive your tweet.  Once someone posts an answer to a question we lose visibility to it for the most part as you would unless you are watching it.  To address the issue you're running into, initially you stated the following:

The problem seems to be with the use of the ISAPI redirect method, using the Tomcat Connectors/Jakarta. Accessing Jira directly on the install port (8180, for instance) works fine.

Connecting directly to the :port does work.

Based on the above, it appears you may be running into JRASERVER-64982.  You can fix it by adjusting the max character limit for file paths on the IIS box using the instructions in JIRA elements fail to render with HTTP 400 error.

Please review JRASERVER-64982 and follow the steps in JIRA elements fail to render with HTTP 400 error.  Once you have done that if you're set:

  1. Vote on the issue and you'll be notified of any updates/fixes
  2. Let us know the issue is resolved


Going forward, if you need immediate assistance and you have a license that is beyond a starter license use that SEN and you will get to Standard Support as there has been a change to the Starter License Support structure per the blog post titled We're updating our support offering for server starter (10-user) licenses.

Cheers,

Branden

Hello Branden,

Thanks for the reply. I am at the moment restarting the server with the registry change and hopefully this will fix the issues.

I did see the changes for the support structure. It's not that it's not worth it (Jira is wonderful), but we are a very small team (5) so justifying paying 1,800 USD per year is going to be a hard sell for my team. Hopefully you can create some "per incident" fee or similart, or offer a "non starter" license for < 10 users that includes support as it did before.

It finished rebooting and now everything works as before. Thanks a lot for your help!!!

Hi Rodrigo,

I'm very happy to hear that helped!  I definitely understand the constraints of a small team.  If you have any further questions please don't hesitate to reach out to the Community and if you have a Starter license we'll be made aware of the questions immediately.  It may take a day to get back to you due to the volume of questions but use the Starter License to create a post and we'll be notified and help from there.

Cheers,

Branden

0 votes
Gaston Valente Community Champion Jul 19, 2017

Rodrigo,

 

do you have the possibility to test if this happens from the server locally with no intermediaries?

are you using a proxy or some form of redirection?

it's strange, i have similiar problems caused by a misconfiguration at iis 

Hello,

I have just tried directly from the server Jira is installed and it's exactly the same issue. I don't think it has anything to do with proxys or things like that.

In my office we just have a firewall (Sophos) and no proxy.

But now that I think of it, I do have a redirection of sorts: Jira is installed on the usual port, but I use the IsapiRedirect method to make it work as a subdomain. My installation is on IIS. By any chance you have the same?

I am trying connecting directly to the :port, instead the subdomain...

Ok, apparently the problem is caused by that. Connecting directly to the :port does work.

Now, I have been using Jira like this for... 2-3 years, without problems. And there was no change on the installation nor anything like that before this started to fail.

Updated to the latest Jakarta Connector (1.2.42) binary and it is still failing.

Gonchik Tsymzhitov Community Champion Jul 20, 2017

Hi, 

could you provide console log errors, warnings from web browsers. 

For example, in google chrome just press Ctrl + shift +c, and click console tab. Hence we can understand a conflict. 

Thanks

 

Hi,

Here is a screenshot of the console after Reloading the page, clearing the console, and pressing the Link button:

 

Captura de pantalla 2017-07-20 a la(s) 18.56.04.pngThe text of the console is the following (I couldn't post it as it triggered some spam detection and I couldn't post the Reply)

https://pastebin.com/0jEzpXiS

Comparing the request that fails (the one using the ISAPI redirect) and the same request but not using the redirect show some differences:

https://pastebin.com/BxK1z6xv

Well, 

1. Could you check it without middleware Microsoft-IIS/8.5 ?  

 

2. And it is reproduce in incognito mode?

Thank you for provide info. 

 

Gonchik

Hello Gonchik,

1. I am not sure what you mean "without middleware"? What is the middleware you are referring? Without the Tomcat Jakarta redirector, i.e., accessing directly the Jira installation on the configured port (8180) then there is no problem. That's what the previous post was comparing the calls actually. But I am not sure if you are talking about this or some other thing?

2. I've just tried in incognito mode in Chrome and it's exactly the same.

Thanks.

 

Hi Rodrigo, 

1. If work without Jacarta redirector is good^) 

2. Which configuration have set between IIS and Tomcat? 

IIS <-ajp13-> Tomcat , any timeouts, cache or keepalive properties? 

 

 

 

Hello Gonchik,

1. Yes, working without the Jakarta redirector is totally fine. Now, one week ago (or maybe days) it was working fine, and nothing changed inbetween, at least to my knowledge. At least not in the server. Maybe the Chrome version got updated, but that would be it.

2. The configuration is very simple:

# workers.properties.minimal -
#
# This file provides minimal jk configuration properties needed to
# connect to Tomcat.

#
# The workers that jk should create and work with.
#
worker.list=worker1

#
# Defining a worker named worker1 and of type ajp13.
# Note that the name and the type do not have to match.
#
worker.worker1.type=ajp13
worker.worker1.host=localhost
worker.worker1.port=8181

I am not sure where to check for the timeouts, cache or keepalive settings you mention.

I tried today changing the redirect from using the Jakarta connector to the IIS ARR/URL Rewrite and I get exactly the same behavior.

I followed the instructions here: https://confluence.atlassian.com/jirakb/integrating-jira-applications-with-iis-using-arr-313467089.html and everything works, except for this problem, that is the same with both.

It's getting very frustrating to have this problem, as a lot of needed forms/actions aren't usable at all. I can't Edit issues, for instance, as the same thing happens.

I tried changing the installation to NOT use the subdomain, but have it use the base URL of the :port configuration, but then several other stuff gets broken (for instance, the Activity Stream doesn't display anything, HipChat integrations are not working, and so on).

I just updated to 7.4.2 and the same thing is happening.

How one does get support here? Apparently for small teams like myself there is no longer a way to get support directly from Atlassian except in this forums, but so far nothing.

I tried to create a bug report but it redirects to the Support page, where it redirects here. So there is no way, apparently, to do anything except post here and hope that at some point, between all the questions, somebody from Atlassian is going to notice and interact with this.

Captura de pantalla 2017-07-31 a la(s) 12.06.45.pngCaptura de pantalla 2017-07-31 a la(s) 12.07.12.png

For the record, I'm posting some more screenshots from the debug tools in Chrome.

Some more info: The "Start Progress" transition doesn't work if I am seeing an Issue from a search filter (the address ends up with ?filter=XXXXX), but if I don't have that, i.e., the address shows just the Issue number, then the button works.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Dec 10, 2018 in Confluence

Organizing your space just got easier - Page Tree Drag & Drop is here

Hi Community! I’m Elaine, Confluence Product Manager. You may have read my earlier post about page tree in space navigation sidebar. I'm excited to share another improvement that helps you organize ...

204 views 6 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you