Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

The Plugin keeps getting stuck, giving page unresponsive error pop up.


We have a custom plugin that was working fine in jira version 8.x but now post upgrade to jira version 9.4.3 we have started facing issues with the Plugin UI.

The Plugin keeps getting stuck and throws out page unresponsive error pop up. We have tried it in our local where it seems to be working fine with the same Jira version i.e. 9.4.3 but on one of our environments it is not working as expected.

In error logs we do not see any error or exceptions. In the console log, we are only able to see some violations related to js but there is no error in the console either. 

Kindly provide any suggestions or resolutions for this issue.

1 answer

0 votes
Rilwan Ahmed
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Mar 19, 2023

Hi @Apoorva Sharma ,

It is better to rebuild plugins when jira is upgraded from one major version to another. (example Jira 8 to jira 9).

Your local instance may not have same config, same data, same plugins as in production jira. 

So my suggestions are:

  1. Always refer to release notes before upgrading the jira. 
  2. Refer preparing for jira 9.0 for developers
  3. Check if issue is reproduced n different browsers like chrome, firefox, edge etc. 
  4. Now that the plugin worked in local instance, try to delete the plugin from production, reinstall the plugin. If still there is issue, restart jira after clearing plugin cache.
  5. If still you have issue, enable debug mode for the plugin, check for logs again. 

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events