Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Show Story Points Indicator on Backlog

Hi! I want to show the story points for a story on the backlog. I have found how I can add a field, but this also adds an entire row making the backlog less comprehensible. I remember in the past there would be a grey circle with the amount of story points written in it at the end of each row of the backlog. How can I set that up?

8 answers

I was able to add the story points by going to Jira Settings > Issues > Custom Fields then search for 'Story Points' and add your project by clicking on the '...' more menu and select 'Configure'. Then, under 'Default Configuration Scheme for Story Points' simply select 'Edit Configuration' and select the project(s) :)

Hope this help!

Andre

I was not seeing story points on my board. I tried this and this solved my issue. Thank you.

Worked for me - many thanks!

Thanks, it worked.

With this help, I could find the problem on my cloud instance as well.

 

It works a bit different:

Settings > Fields > Custom Fields > Select Story Points > ... > Contexts

 

Thanks!

The same problem - I changed Estimation on Srory Points - but this don't work for me. Are there any other settings I have to change?

I am experiencing the same issue. Is there another setting perhaps? 

Had exactly the same issue. The fix I used was:

  • In the backlog, select the '...' button and go to 'Board settings'.
  • In the 'Board settings' menu, select 'Card layout'
  • In the drop-down menu, select 'Story points' from the list then select 'Add'. 

This doesn't add them the way it used to (next to epics, in a grey circle), but it does make them visible in the backlog or board (you can choose to add them to each). 

This doesn't fix the issue at all. It adds it as a new line which is exactly what no one wants. Read the question again.

Like # people like this

Well, it solved the problem for me. Thanks so much for your polite response though :) 

You'll see, if you read my post clearly, that I highlight that it doesn't fully solve the problem in the way that it used to work. However, it at least makes the story points visible, which was the problem that brought me to this thread. 

For those that have a similar issue, and think that having the story points visible is more important than an extra line for each backlog item, then that fix will work. 

Best of luck finding the ideal fix you want. 

Like # people like this

I was able to fix this on my instance. There were two fields available called "Story Points" and we had the wrong one on the screen. Not sure why there were two fields called the same thing but might be something to investigate. 

Try having a look at the field configurations and ensure that you don't have a duplicate :)

Like Guillaume Lederer likes this

@Jack Hiddes: For some reason in my JIRA instance we have two fields called "Story Points". When I changed the field on the Story screen to the other "Story Points" field, the numbers appeared.

This is not typical and may not apply to your instance. My guess is someone created a duplicate "Story Points" field.

Have a look at your list of fields and see if you have duplicates.

Like Lucas Tonon likes this

Thanks, @Andrew Love I got the extra line, but totally worth it to get the story point estimate in the view.

I've seen the story points in the grey circle on a scrum board, but I can't work out how to do it on the Kanban board.

Same issue, it seems like it wasn't implemented for Kanban boards. And that's pretty disappointing...

Like # people like this

@Atlassian, here's another feature request!  Make Kanban Boards display Story Points *the same way* they are shown on Scrum Boards... both in the Backlog view *and* the Active Board view.

Like # people like this

It's the thing that makes me saddest about the "KanPlan" view.

Like # people like this

@Atlassian this seems like a "miss".  Plain & simple.

Like JeltzProstetnic likes this

I've added a suggestion for Jira Cloud to show the story points badge on the kanban backlog: https://jira.atlassian.com/browse/JSWCLOUD-18475

I believe that voting for the issue is one way to get the matter on / bump it up the priority list.

Like Dominic Marmion likes this

@Amy Bailey the whole Jira cloud is a miss.

It's missing because the metric for Agile Kanban shouldn't be story points, it should be time to resolve stories. That said, most teams find themselves in hybrid management practices, ScrumBan if you will. Measuring some sort of velocity, or allowing Product Management teams to consider complexity in their prioritization is helpful. Rather than being forced to exercise certain methodologies, Jira should favor on the side of configuration and allow each team to shoot themselves in the foot, and at most provide recommended guidelines if they want to get preachy. 

So after running through everything previously posted here, I found that if you go to your project settings  > Fields > In the top right click the "(gear) Actions" dropdown and select Edit Fields > scroll down to Story Points and click "Required" on the right for Story Points > Go back to your Projects backlog and try and create a new issue, it will bring up the full edit for an issue and yell at you for not having a story point value. Go ahead and enter a value and then create the issue. You will now note that it shows the story point value both on the issue in the backlog and in the info panel on the right for the issue (click on the issue to see this). Now you can go back and change Story points from Required to Optional and all future issues will have story points as an editable field on the right-hand info panel.

SOLVED! We've been dealing with this issue for months, and this did the trick!  Thank you!

Thank you Brett. This resolved our issue as well. You should go work for Atlassian Support team as their advice elsewhere on this community did resolve the issue 

Like Anne Blaisdell likes this
0 votes
Ignacio Pulgar Community Leader Dec 18, 2017

Story points are automatically shown in the backlog as soon as you set a value in the story being shown:

story-points.png

That's what I thought! But exactly the grey circle with the estimation you show in your printscreen does not show up in my backlog, also after I estimated it. Looking for the setting that removed it / to add it back in the list.

In my case it shows the priority by the way, a red, orange etc. arrow.

Ignacio Pulgar Community Leader Dec 18, 2017

Maybe it is one of those new kanban boards, with backlog as a new feature, instead of a scrum board?

Ignacio Pulgar Community Leader Dec 20, 2017

I think you can fix it by following these steps:

  1. Go to Board > Configure > Estimation
  2. Change Estimation from Issue Count to Story Points
Like Dan Elsworth likes this

No. Not working at all. even on scrum board.

I have the exact same issue, have followed all the suggestions in this thread and still no story points in the grey bubble on the backlog view of a scrum project (JIRA cloud).  We have the priority indicator but cannot get story points to show in the bubble and NO a 2nd line with the story points is not acceptable. 

Like # people like this

The setting for Scrum boards, it's in the Board Settings > Estimation section. So each of your boards in a project could be different. 

Jira Story Points Grey Bubble.png

@Ignacio Pulgar this is for next_gen boards. Classic boards don't have that.

As mentioned above only the Story points are being shown in the backlog as a bubble.  I just realized earlier that I was actually inputting Story Estimates instead of Story Points.  Not all issues have it sho I configured it using Custom Fields>Open Story Points> Click Context tab>Edit it and apply it to all your issue types.  Hope this works for you too.

0 votes

This issue was happening to me when I was creating a new project. I wanted to say that I had forgotten to create a board at all, so I could see the project and edit all the fields, but because i had not created a BOARD, the grey bubble for the estimate did not show up. When I went to create a Scrum Board, it configured the backlog to include the grey bubble with all of the numbers. Problem fixed. Make sure you have a Scrum Board created, or this will be blank.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Software

How to create Jira issus from Excel file?

When to use CSV importer When managing your processes in Jira, there are many occasions where you need to create a lot of tasks. Creating them one by one will cost you a lot of time and effort and i...

4,528 views 22 32
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you