Remove sub-task from Scrum/Kanban board

Hi,

I would like to know if there is any way to not show the sub-task on the Plan mode of the boards either in the Kanban and Scrum views. I would like to see on those boards only the User Story status without all the tasks beneath.

Andres

8 answers

1 accepted

0 votes

By default, Sub-task should not appear in the plan mode. They will only appear in the issue detail view on the right pane when you click on issue in plan mode. No configuration involved, as far as I know. In the other hand, sub-task will appear as individual card in the Work mode by default.

If you don't like this to appear in the work mode and only can be seen by opening the issue detail view or issue view in JIRA, you can create a quick filter to exclude sub-task.

Using a quick filter is perfect. What is the query to exclude sub-tasks?

got it

type not in subTaskIssueTypes()

You can add a "Work sub-filter" which is basically a quick filter that is always on

Check your agile board configuration. I found that I had unintentionally set swimlanes to "Stories". When I changed it to "No Swimlanes", problem solved!

Thanks Jnet, this worked like a charm! I never even thought to choose "No Swimlanes", I figured that would take out the swimlanes entirely.

Thanks again!

This saved me too.. thanks for the tip

Thank you!  Worked like a charm

 

This can be done by going to the Board Configuration and clicking in "Edit Filter Query"

Change the query to include this: AND type != Sub-task

I have a similar issue, where I dont want to see the subtasks in the Work view of the new Greenhopper Agile Boards. I understand the positives of this feature, but would like the ability to turn it off. My main driver is that the only subtasks we put on our stories in jira are acceptance tests, which are unnecessary to see in the work view.

I tried sellerjd's JQL to filter out sub task issue types, but this doesnt work for us because it still shows a summary line for each task as though it had subtasks, but there are no subtasks under it (see below). This is slightly better, but we still cant see the estimate or what swim lane each of these stories is in.

Please let me know if you have any suggestions to help with this issue.

I have this same issue. Did you ever find a solution?

Nope, noone ever responded to this. Our solution was to stop using subtasks for our technical tasks. What we now do instead is to just use a custom field with wiki markup to add simple one-line bullet points (* [Task Description]) for tech task, and then strike through them as we finish (-- [Task Description] -- ). Since we dont estimate or keep of the tech tasks in any other way, this works for us, though it feels like a workaround.

If you asked the question in a standalone question you might have gotten an answer. Asking a new question in another question is not the optimal way of doing things.

Ivar, I don't understand the point of your comment. I was corresponding with Dwight because I had the same problem. I provided a suggested solution for Dwight earlier today.

If it's useful to anyone: changed the kanban board sub-filter from: fixVersion in unreleasedVersions() OR fixVersion is EMPTY to: (fixVersion in unreleasedVersions() OR fixVersion is EMPTY) AND type not in subTaskIssueTypes()

0 votes
Eddie Webb Community Champion Sep 22, 2013

Check your config for the board.No sub-tasks should show in the planning view. They will show in the work view however (how else does the team know what to run with)

See similar quiestion https://answers.atlassian.com/questions/108172/planning-sprint-in-greenhopper-6-with-scrum-board-no-subtasks-shown

@jnet, I responded to Dwight "complaining" that he didn't get an answer to his question. So I just informed him that he might have more luck if he asked his question as a standalone question instead as a comment in another question.

It's possible to remove sub-tasks from the board in work mode by editing the board filter.

I think the easiest and most maintainable way is to use the 'Board Filter', found in Board Settings/General/Fiters/Saved Filter/Edit Filter Query.

just add " and issuetype not in (sub-task) " to the existing filter before the 'Order By' phrase of the query and save the query/filter (whatever YOU want to call it).

best!

Suggest an answer

Log in or Join to answer
Community showcase
Teodora [Botron]
Published Thursday in Marketplace Apps

Jira Inferno: The Nine Circles of Jira Administration Hell

If you spend enough time as a Jira admin - whether you are managing a single, mid-sized instance, a large enterprise one or juggling multiple instances at once - you will eventually find yourself in ...

461 views 1 15
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot