Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,455,373
Community Members
 
Community Events
175
Community Groups

Receiving an error from Kanban > Roadmap 'JQL filter is blocking your roadmap'

Hello,  I just created this project and admittedly a bit rusty on setting up Kanban vs Scrum which I have more practice with.  On my Kanban board I only want to display non-Epics so perhaps in hiding Epics from display caused this.  Honestly I'm not sure but I wasnt able to find specific help for this Roadmap error 'A JQL filter is blocking your roadmap'

6 answers

Hey I got the answer from Atlassian support. 

 

Evidently the standardIssueTypes() does not return Epics. (They suggested this is the definition, but I suspect it's a change)

To fix it you can replace 

issuetype in standardIssueTypes()

with 

issuetype not in subTaskIssueTypes()

or 

(issuetype in standardIssueTypes() or issuetype = epic)

Thank you so much for looking into this, Thomas! 

Interestingly enough, it works for me now again. I hadn't updated the JQL yet.

I'm raising a high priority ticket and referencing this Community page, my users are seeing the same issue as you all, and the JQL is similar to @Thomas Holt :

filter: project = GMSUI AND issuetype in standardIssueTypes() ORDER BY Rank ASC

Glad to see it's not just me!

1 vote
Trudy Claspill Community Leader Feb 17, 2022

Hello @Kendra Clark _FMT-PM_ 

Welcome to the community.

Is that the full message you see?

When I adjust the filter on my board to exclude Epic issues, this is the full message I get:

A JQL filter is blocking your roadmap
There’s a JQL filter applied to your board, and it’s preventing the roadmap from displaying epics.
Your board admin can adjust this filter to unblock the roadmap, without affecting the set up of your board.
This clearly states that the problem is epics are being prevented from displaying on the roadmap.
Roadmaps are based on displaying the timeline for Epics and their children (in Jira Standard subscriptions). Your board filter must include Epics. 
If you don't want the Epics to display on your board, you could add a Quick Filter that you could activate to hide the Epics. Or, you can turn on the Backlog screen and the Epics panel (on the Columns page in Board Settings) and then the Epics will display only on a side panel in the Kanban Backlog screen.

Nice to meet you virtually!

Here is the full message with the conflict:

“A JQL filter is blocking your roadmap

There’s a JQL filter applied to your board, and it’s preventing the roadmap from displaying epics.

Your board admin can adjust this filter to unblock the roadmap, without affecting the set up of your board.

Learn more about displaying epics on the roadmap”

Trudy Claspill Community Leader Feb 17, 2022

So, then, yes, the filter on the board is excluding the Epic issue types. You'll have to change the board filter to include the Epic issue types to unblock use of the Roadmap feature.

And then you can use either of the suggestions I provided if you don't want to show the Epic issue cards on the board display.

If that addresses your issue, please mark the answer as Accepted. If you have additional questions, please let us know.

Like Nick Fossey likes this

I seem to be having this problem and as far as I can tell the filter is not excluding epics. 

here's my board

filter: project = CON AND issuetype in standardIssueTypes() ORDER BY Rank ASC

 

I checked to make sure standardissuetypes() included epics and it does. 

Like Gregory S Williams likes this

We are also encountering a similar problem, however, it is only occurring when we use a query similar to Thomas' above.

For this query on a project board, we are unable to view the Roadmap. The board also now only contains Story issue types:

project = SREENG AND issuetype in standardIssueTypes() ORDER BY Rank ASC

All other projects have a query similar to this, and we do not have any issues viewing their respective roadmaps: 

project = DATA ORDER BY Rank ASC

We could modify the first query by removing the standardIssueTypes() piece, but we are hoping to not include subtasks on the board. 

Same as above is happening for me as well all of a sudden.

We are having exactly the same issue, and we are not filtering out the Epics too.

Seems like there is a bug or something is up.  This is a standard query we have used on our board for over a year and today it just started doing this too. 

I tried another thing that seemed to have worked for me. It was an interesting change. I added all my epics to a new column (through board settings). I called that column "Epics" once all epics were added to that column, I went to board settings and deleted that column. It seems that when the column was deleted, it took the epics with it, and did not display them anymore. However, the epics still exist and show in roadmap. 

 

If you go through this route and decide you still want epics to show up on kanban board, simply expand the epic and change it's phase from "epic" to "selected for development" column (as an example). The epic will show up again on the kanban board.

0 votes

I don't see that the change has been revirted, the issue is still reproducible for me.

ETA: NEVERMIND. Found what I was looking for. Board Settings > General > Edit Filter Query

Chiming in to possibly resurrect this issue. 

The users for one of our Jira projects are reporting the "A JQL filter is blocking your roadmap In order to use the roadmap, you need to adjust the JQL filter to show epics. Changing this filter won’t impact the setup of your board." error. 

The thing is, this particular company-managed Kanban project has THREE boards. I'll call them P, DC, and C.

Board C shows the roadmap just fine.

Boards DC and C show the "A JQL filter is blocking your roadmap" error. Yes, I've checked, Roadmap is turned on for those boards. Still get the error.

I cannot for the life of me figure out how to modify JQL filters to apply to these boards, let alone in a way to resolve this issue. I can only create/save JQL filters for basic issue searches. Nothing I can find tells me how to apply that to the roadmap for a specific board for a specific project.

Help??

I got a response from Atlassian and they reportedly fixed it:

From the (awesome) agent:
I did some digging on my end and found some internal discussions about what caused this issue. It looks like there was a change made on the backend with unintended consequences for classic Roadmaps, and this change has since been reverted (which makes sense as to why I can no longer reproduce the issue)

Awesome! Works now for me :)

Like Gregory S Williams likes this

I don't see that the change has been revirted, the issue is still reproducible for me. I mean that I excluded Epics from my board and after that the Roadmap got broken.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events