Project Workflow Blank Edited

I wanted to change the workflow associated with a project. I followed the instructions found at Managing workflows for projects. The steps are as follows:

  1. Choose Settings > Projects. The Project Summary page is displayed.
  2. Click Workflows on the left of the Project Summary page (you can also click the More link in the Workflows section in the middle of the screen). This is the current workflow scheme used by the project.
  3. Click the Switch Scheme link to display the Associate Workflow Scheme to Project page.

  4. Select the relevant workflow scheme from the Scheme list and click the Associate button to begin the migration process. 
    Each issue has to be in a valid status. The valid statuses for an issue are defined by its workflow. This means that when changing a workflow, you may need to tell JIRA the status for specific issues after the change.

  5. A screen displays that indicates the progress of migrating all the project's issues to the updated scheme's workflows. Acknowledge to finish the process.

When I get to step 3 there is no link. Instead the window on the right of the page where my workflow should be is missing and there are no buttons or links.

What is even more curious is that if I click the Summary link on the left of the Project Settings page and then click on the Workflow link for the project in the window on the right labeled Workflows it will take me to the "Workflows" section on the left of the Project settings page and the Workflow is displayed at that point. However, there is still no link for Switch Scheme.

 

I have a screen shot if it would be helpful to resolve this issue.

2 answers

1 accepted

Branden,

After trying a variety of solutions, including creating a new database, backing up JIRA and moving to the new database I found the problem.

I had more and more issues loading pages within JIRA. Primarily pages that involved administration. This all started because I was trying to find out why I could not change a project's workflow. Then, I also could not change a user's permission scheme. That is when I came across this help page Unrecognized function 'getJiraHelpUrl'. It turns out my soy plugin was turned off.

Now, I never mess with system plugins. The only user-installed add-ons I have are "Atlassian Universal Plugin Manager Plugin" and "JIRA Software Chinese (China) Language Pack. Three things happened recently before I started having my problems. My UPM Plugin updated; I updated JIRA to v7.4.2, which forced me to move to a new database because the collation and character type of my old database started throwing errors in JIRA; and I installed, demoed, and uninstalled confluence.

I don't know which of these was responsible for messing up my instance of JIRA by disabling the soy plugin but I am happy to report it is fixed. The only reason I went into detail letting you know about my environment is so if there is a path that causes JIRA to break you know about it and what the likely solution might be.

 

Regards,

TJ

0 vote

Hi Theodore,

Are you on Cloud or Server?  If you are on Server you would see the following:
Screen Shot 2017-08-04 at 10.11.33 AM.png
If you're on Cloud using the new UI you'll see the following:

 

Screen Shot 2017-08-04 at 10.12.31 AM.png
I split the permissions as it shows in Managing Global Permissions to see if that would make a difference if the user was not a full system admin but that does not make any difference either.

Take a screenshot of what you're seeing and we'll go from there.

Cheers,

Branden

Branden,

 

I attached a picture of what my screen looks like when I go to settings->Projects, select the project, and click "Workflows"

 

We are using our own native server to host JIRA. I cannot say when this issue started because it has been awhile since I wanted to change a projects workflow.

 

However, I had issues with JIRA and had to perform a re-index and repair a couple of problems after I installed and uninstalled Confluence.

 

Regards,

 

Theodore Redlich

Hi Theodore,

Thanks for the screenshot.  I want to see if it's a plugin that's causing this because this has been reported in the past.  The easiest way to determine this is to put JIRA in Safe Mode and see if the issue re-occurs:

  1. Open the 'Manage Add-ons' or 'Find New Add-ons' page from the application's administration console
  2. Click the Enable safe mode link at the bottom of the page.
    The 'Do you wish to continue?' dialog box appears.
  3. Click the Continue button to confirm the operation.
    All user-installed add-ons are disabled and your application now runs in safe mode, as indicated by the message on the page.

If it doesn't, re-enable the add-ons one by one until the issue re-occurs and that will be where you'll want to focus.

Cheers,

Branden

Branden,

I entered safe mode and went to the screen that I sent you a screen shot of and it is still blank.

 

Also, as an additional test I tried from a different browser (Mozilla Firefox) and it also is showing the same blank page.

 

Regards,

Theodore Redlich

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 21, 2018 in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

1,243 views 10 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you