Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Problems with forge tunnel

Hello everyone, 

I am very new to Atlassian Forge and am currently trying to develop an app using Forge.

For the installation, I have followed the instructions on this page: https://developer.atlassian.com/platform/forge/getting-started/

 

I am able to deploy and install the app on my local instance but unfortunately I am running into the following error when using forge tunnel.

 

Checking Docker image... 100%
Your Docker image is up to date.
docker: Error response from daemon: invalid IP address in add-host: "host-gateway".
See 'docker run --help'.

Forge tunnel initially worked but all of a sudden it stopped working (without me changing anything).

 

What I've tried already:

  • Uninstalling and reinstalling forge/npm/node
  • Starting/restarting docker
  • Deleting the forge tunnel image and re-downloading it again. 
  • Upgrading forge tunnel

Versions used:

  • Node: 12.22.1
  • Ubuntu: 18.04.2 
  • npm: 7.16.0
  • Docker: 20.10.2
  • Forge: 1.4.0

 

Thanks in advance!

2 answers

0 votes

Hi,

do you have found an answer? I am facing the same issue.

I am using forge/docker inside a linux vm on a windows host.

Thx

Hello @Gernot Grames

unfortunately I have not been able to fix the problem yet. 

I also wrote a post on the Atlassian Developer Community and got some hints: 

https://community.developer.atlassian.com/t/problems-with-forge-tunnel/48834

 

Maybe that could help you :) 

Hi

Actually, I think, it is a problem with the docker.

Anyway, remove && install every time solve this issue for me...

Sometimes it needs to install twice  (remove && install && install) :)

I don't know why but it works )

sudo apt-get remove docker-ce docker-ce-cli containerd.io
sudo apt-get install docker-ce docker-ce-cli containerd.io
sudo apt-get install docker-ce docker-ce-cli containerd.io

Docker 20.10.7
Ubuntu 20.04.2 LTS

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Marketplace Apps & Integrations

☕️ Monday coffee with Jexo: Weekly Atlassian news roundup | 21st June 2021

Hi community 👋, as every Monday we're bringing you a quick update on what happened in the Atlassian ecosystem last week. There were a few interesting events like for example the announcement of th...

63 views 0 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you