Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,477
Community Members
 
Community Events
176
Community Groups

No longer able to drag and drop branch rules in automation?

Edited

Within the last week, I was able to drag and drop branch rules so that one branch rule is within another (see below).

image (1).png

Now, I can't drag and drop branch rules at all within the same automation. Anyone know if this is a bug or if something with the functionality that changed? Clicking "Add component" where I want the branch rule to appear (beneath the "Create a new Task" action doesn't list branching as an option, but I've been able to get around this in the past by dragging and dropping branch rules.

image (2).png

3 answers

1 accepted

0 votes
Answer accepted

Hi @dowens1 -- Welcome to the Atlassian Community!

I have seen several posts about this behavior before, and I hypothesize it is an accident/defect that it works sometimes.  If nested branches were intended to be supported they would be in the documentation...probably with several articles written describing use cases and limits.  I'd welcome input from the automation dev team if this is intended to work.

And for the rule you have shown, technically the "branch" on most recently created issue gets converted to in-line code.  Branches on more than one issue get run in parallel and asynchronously, and so I would guess performance issues and potential errors could be why this structure may not be supported.

Kind regards,
Bill

Thanks for sharing this, @Bill Sheboy. Definitely seems like a bug to me. What do you mean by "the 'branch' on most recently created issue gets converted to in-line code"?

Apologies in advance for the long explanation  :^)

For branches on one-and-only-one issue (e.g. last created, parent epic, current issue) when the rule gets parsed and run, the rule steps runs in the order you see them.  Essentially the code is "in-lined" with the loop "unrolled", in dev-speak.  This has been confirmed by a few Atlassian folks in community posts.

However, when a branch is/could be on more than one issue (e.g. for sub-tasks, JQL, related issues, etc.) each issue/value gets run separately and in parallel for the branch steps.  And there is no guarantee of the processing order or even that the last one will finish until the very end of the rule's other steps.

Here's an example:

  • trigger: manual
  • branch: on parent epic
    • action: do some things A
  • action: do some things B
  • branch: on JQL for multiple issues
    • action: do some things C
  • action: do some things D

The current, actual order of processing will be:

  1. trigger happens
  2. things A inside the branch
  3. things B
  4. unknown from this point forward, as "things D" could happen intermixed with the processing of "things C" for the branch issues

I believe there is a suggestion to add an option to finish such a branch prior to continuing, similar to what is available for the Send web request action.

Update on this in case anyone runs into the same issue. I was able to check tasks before adding a new one by using the Lookup issues action, adding a variable, and then doing a compare on that variable. Picture1.png

0 votes
John Funk Community Leader Dec 15, 2022

Hi @dowens1  - Welcome to the Atlassian Community!

It's probably because the new one has an Else-if in it. Those are different because of the structure than regular If conditions or other conditions. 

Thanks @John Funk! So you're suggesting that if I had a second If, in place of an Else-if that I'd be able to do this?

I tried doing this with the same result as before and I can't drag and drop the branch rules in the If component above either.

John Funk Community Leader Dec 15, 2022

Make sure you drop right in the line - it's a little finicky sometimes where it will let you put things. The other option is to add a new Condition and drop that in the right place. 

That is a frustrating element of the automation rule builder and the first thing I thought I was doing wrong, but it doesn't seem to be the issue here. Thanks again for taking a stab at this, John!

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
TAGS

Atlassian Community Events