Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

Recognition

  • Give kudos
  • My kudos

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Mobile app in Jira 8.3 "We're missing something"

Trying to get the mobile app working on Jira 8.3.2, and getting the "We're missing something" error, as in a plugin is missing.

Jira was recently upgraded from 7.9.2 to 8.3.2. Jira is run with SSL through Tomcat, and we can reach it through a mobile browser.

According to the KB article, there should be two plugins:

  • Jira Mobile REST API Plugin
  • Jira Mobile

We have "Jira Mobile" v3.2.5, but the plugin in the bundled (/WEB-INF/atlassian-bundled...) looks to be v1.0.1 of "Mobile plugin for Jira". This one has modules named similarly to the plugins mentioned in the KB.

I tried re-installing the plugin from the app folder and disabling the "Jira Mobile" plugin, but none of this worked.

I've tried searching for a .jar of the REST plugin, but couldn't find anything.

Anyone else experiencing similar issues?

 

1 answer

0 votes
Andy Heinzer Atlassian Team Sep 06, 2019

Hi Daniel,

Those versions look to be correct for a Jira 8.3.2.   I am interested to learn if perhaps one of these plugins might be disabled within Jira.  If that happens, it could cause this error.  Try going to in the UPM in Jira; Cog icon -> Manage Apps -> Manage apps -> select System form the drop down and search for the term mobile you should then be able to expand both plugins to see all the modules enabled for each, like this:

Screen Shot 2019-09-06 at 11.40.28 AM.png

I suspect that in your system if one of the modules is disabled, you won't see the same '39 or 39 modules enabled'.  But you can then click into that link in order to try to re-enable the module that might be disabled.

Alternative, you can try to run the following SQL command against your database to see if perhaps one or more module/plugin has been flagged to be disabled in the database:

select * from pluginstate;

This will return a list of all plugins that have been disabled in your Jira site.   You could remove the entry from that table in the database and then restart Jira to see if that might help to make sure it's enabled again. If you're not sure which values should appear there, feel free to share the results you have either in the UPM or via the SQL query.

Andy

Hi Andy,

Thanks for the feedback. I did indeed check the modules, and all 19+39 were enabled:

Screenshot 2019-09-09 at 10.15.53.png

Running the SQL query, they also seem to be enabled:
Screenshot 2019-09-09 at 10.18.18.png

I have a ticket open with support and will share the findings here once we solve the issue, but I thought I'd share it here as well in case someone else was experiencing the same issue.

Regards,
Daniel

Like Dave_Liao likes this

Wondering if you've resolved your issue?  I'm experiencing the same problem on our dev site that I've just upgraded.  The confluence app works fine against our upgraded dev confluence site.

I also have an open issue with support.

Hi,

Yes, we did manage to solve it - the problem in this case was a third party SSO plugin that was redirecting all login traffic to ADFS, including the mobile app.

Once we whitelisted only the internal IPs, connecting from a mobile network worked just fine.

/Daniel

Like # people like this

Thank you.  We added an exception to our third party SSO plugin for /server-info.  This allowed the app to get the version back from the server before sending traffic back to adfs.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Software

How to create Jira issus from Excel file?

When to use CSV importer When managing your processes in Jira, there are many occasions where you need to create a lot of tasks. Creating them one by one will cost you a lot of time and effort and i...

4,633 views 22 33
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you