Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Microsoft Teams for Jira - Jira ID is not working - Unable to authorize

Hi Team,

I have installed 'Microsoft Teams for Jira' app in my Jira instance and configured the Application link as per the documentation. Also, installed the Jira Server App on my teams.

When I try to connect for the first time for using the BOT from Teams, I am able to successfully authorize and use the bot.

But with the same JIRA ID my team members are not able to authorize, they get the following error, screenshot FYR,

image.png

After they try it gets auto logged out for me as well and I get the same error.

Any inputs much appreciated.

Thanks.

3 answers

1 accepted

1 vote
Answer accepted

Hi All,

The following solution worked for me,

  1. Uninstall the MS Teams Integration App
  2. Restart Jira
  3. Reinstall the app

More details at here.

Thanks

Hi All

I also have the exact same issue as devsuresh2005 and similarly when I reinstall the Add-on in Jira I also get the same JIRA ID and the same issue.

Has anyone had any luck with this issue since posting.

Appreciate any assistance.

Sharyn

Hi @devsuresh2005  Check the Microsoft Teams for JIRA plugin Configuration to get correct JIRA unique Id. Install JIRA server in JIRA Server connector in MS Teams. 

Then type Connect >> Press enter >> Enter JIRA ID.

As per the screenshot, it seem that you are entering worng JIRA id , might space in unique ID. 

Hi Vikrant, thank you for your inputs but the same JIRA ID works for the first time but not working for others and for me too from the second time. Thanks.

Try to reinstall the add on in JIRA . Then use new jira unique ID available in Configuration. 

Hi Vikram, thank you for your inputs again. I tried it multiple times (uninstalling the add-on Jira and the app on MS Team and reinstalling everything fresh), I get the same JIRA ID and the same issue.

As soon as I reinstall, the first person is able to authenticate successfully then if anyone else tries to authenticate with the same Jira ID then it gets logs out for the first person as well and nobody is able to log in until I reinstall again.

Weird right? :(

Thanks.

Hi @devsuresh2005  H.mm... it weird but possible to fix. I think some steps are missing. Have you tried to create application link again .Check correct public key is added in Application Link, oathkey and Consumer Name is correct. 

 

Are you sure you are using JIRA server not cloud ?

 

 Let me know, we will try to fix.

Thanks

Hi @Vikrant Yadav ,

Thank you for your time.

Here is the screenshot, it works well for the first time.

image.png

And here are my incoming authentication configurations,

image.pngimage.png

And I have not configured any outgoing authentications FYI.

Hope this helps. 

Thanks.

@devsuresh2005  You have already performend all troubleshotting steps tried to reinstall, create new application link  and tried to reconnect but still not working. 

I suggest you to raise a ticket with Vendor, vendor can suggest what is the issue with key. 

you installed plugin from Marketplace right ?

Thanks

@Vikrant Yadav

Thank you again for your valuable time. 

Yes, I installed it from the marketplace.

I did post in support, will keep posted if I hear back.

Thanks.

This is support email address :- MicrosoftTeamsIntegrationsSupport@softserveinc.com

 

Thanks!

Like devsuresh2005 likes this

@Vikrant Yadav 

I did notice this error,

ERROR      [c.microsoft.signalr.HubConnection] HubConnection disconnected with an error: Server timeout elapsed without receiving a message from the server

Any inputs?

Thanks.

You can use Webhook for now, so that you can notification in MS Teams Channel when issue get updated or Created. But with this you can't create or modify issue.

I have tried to reinstall everything on my side like JIRA Connector in MS Teams and MS Team for JIRA plugin. It works fine. 

 

When you click on Connect , it ask for your Office365 credentials ? On my side it ask for O365 username then TLS Certificate popup comes i click on that then only JIRA ID windows comes. 

Thanks,

Vikrant

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

Introducing External Collaboration for Confluence

We’re excited to introduce external collaboration for Confluence, now available in early access. It is available to preview for Confluence Cloud Premium and Enterprise customers. (If you're not on ...

199 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you