Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

_MSG_gadget errors and application tab error

Hello,

1. I've got problem with _MSG_gadget errors at titles in dashboard.

2. I see an error "The Atlassian Marketplace server is not reachable. Available application updates will not appear on this page." in applications tab.

Everything happend after installing SSL certificate to JIRA. I saw many questions about this topic but nothing helps. For example for point 2. i followed this instruction: https://confluence.atlassian.com/confkb/the-atlassian-marketplace-server-is-not-reachable-due-to-peer-not-authenticated-321850263.html?utm_medium=hercules-issue-view&_ga=2.124477066.1657909378.1553608288-567659681.1532674618&utm_source=SAC&utm_content=420060

but error has not disappeared. Maybe something is wrong with my JVM ?

2 answers

1 accepted

1 vote
Answer accepted
Petr Vaníček Community Leader Mar 28, 2019

Hi,

try to figure it out by this troubleshooting article.

https://confluence.atlassian.com/jirakb/how-to-fix-gadget-titles-showing-as-__msg_gadget-813697086.html

Where did you install new cert? Into reverse proxy or JVM keystore?

I've installed cert into

"C:\Program Files (x86)\Java\jre1.8.0_191\lib\security\cacerts"

AND

"C:\Program Files\Atlassian\JIRA\jre\lib\security\cacerts"

Petr Vaníček Community Leader Mar 28, 2019

Try to follow that article and you will see if it will help.

Petr Vaníček Community Leader Mar 29, 2019

1) remove your domain from nonproxyhosts, you can set here localhost if needed and remove nonproxyport

2) can you share your INSTALL-DIR/conf/server.xml?

After change domain to localhost and remove nonproxyport problem occurs again.

The part of engine and connector is enough ?

<Server port="8005" shutdown="SHUTDOWN">
<Listener className="org.apache.catalina.startup.VersionLoggerListener"/>
<Listener SSLEngine="on" className="org.apache.catalina.core.AprLifecycleListener"/>
<Listener className="org.apache.catalina.core.JreMemoryLeakPreventionListener"/>
<Listener className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener"/>
<Listener className="org.apache.catalina.core.ThreadLocalLeakPreventionListener"/>

<Service name="Catalina">

<Engine defaultHost="localhost" name="Catalina">
<Host appBase="webapps" autoDeploy="true" name="localhost" unpackWARs="true">

<Context docBase="${catalina.home}/atlassian-jira" path="" reloadable="false" useHttpOnly="true">
<Resource auth="Container" factory="org.objectweb.jotm.UserTransactionFactory" jotm.timeout="60" name="UserTransaction" type="javax.transaction.UserTransaction"/>
<Manager pathname=""/>
<JarScanner scanManifest="false"/>
<Valve className="org.apache.catalina.valves.StuckThreadDetectionValve" threshold="120"/>
</Context>

</Host>
<Valve className="org.apache.catalina.valves.AccessLogValve" pattern="%a %{jira.request.id}r %{jira.request.username}r %t &quot;%m %U%q %H&quot; %s %b %D &quot;%{Referer}i&quot; &quot;%{User-Agent}i&quot; &quot;%{jira.request.assession.id}r&quot;"/>
</Engine>

<Connector acceptCount="100" connectionTimeout="20000" disableUploadTimeout="true" enableLookups="false" maxHttpHeaderSize="8192" maxSpareThreads="75" maxThreads="150" minSpareThreads="25" port="80" proxyName="mydomain.se" proxyPort="443" protocol="HTTP/1.1" redirectPort="443" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^\`&quot;&lt;&gt;" useBodyEncodingForURI="true"/><Connector SSLEnabled="true" acceptCount="100" clientAuth="false" connectionTimeout="20000" disableUploadTimeout="true" enableLookups="false" keyAlias="jira6" keystoreFile="C:\Program Files\Atlassian\JIRA\jira6.pfx" keystorePass="changeit" keystoreType="JKS" maxHttpHeaderSize="8192" maxSpareThreads="75" maxThreads="150" minSpareThreads="25" port="443" proxyName="mydomain.se" proxyPort="443" protocol="org.apache.coyote.http11.Http11NioProtocol" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^\`&quot;&lt;&gt;" scheme="https" secure="true" sslProtocol="TLS" useBodyEncodingForURI="true"/>
</Service>
</Server>
Petr Vaníček Community Leader Mar 29, 2019

Are you running Jira under dedicated user and not under Administrator? If not you should run it with user like 'jira'.

In both connectors:

Try to configure port values to 8080 for http and 8443 for https. Proxyport values leave as it is. Is problem still occurs when accesssing jira over java ports (like https://domain.se:8443 or https://ip:8443 in case of localhost testing)? 

Are you open to solution like reverse proxy (for example with nginx)? From my experience sometimes is little bit problematic run HTTPS with own modified keystore directly on java ports.

If you want try it follow this: 
https://confluence.atlassian.com/jirakb/integrating-jira-with-nginx-426115340.html

So if i change to port values 8080 and 8443 all errors are visible again.

If i set -Dhttp.nonProxyHosts=mydomain.se|*.atlassian.com everything working fine. But it's probably bad solution...?

I run jira under Administrator

Petr Vaníček Community Leader Mar 29, 2019

Your instance looks strange. So you are not using any reverse proxy, but you configure it in parameters, why?

When you will use basic connectors (for 8080 and 8443) in server.xml (without any proxy parameters). Is it working correctly on java port 8443 (you will need also set base url to this url with port)?

If yes - try to run nginx as reverse proxy - it's much easier than "playing" with keystore.

1 Jira Applications with SSL Configured - all results with connection succesful

2 Jira applications with port forwarding configured - I don't think that there is some application with port forwading. I've configured JIRA at config.bat to work on ports 80 and 443.

3 Jira applications with a broken Application Link - there's no such an error in atlassian-jira.log

Jira applications with a broken Proxy configuration -  I've added to JVM those parameters:

Dhttp.proxyHost=mydomain.se
Dhttp.nonProxyHosts=mydomain.se
Dhttp.proxyPort=443
Dhttp.nonProxyPort=80

Dhttp.auth.ntlm.domain=DOMAIN

And that helped me with _MSG_gadget

But there's still problem with "The Atlassian Marketplace server is not reachable. Available application updates will not appear on this page." in applications tab. So the problem is probably still with proxy settings. What else should i add there ?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Software

Presenting the "Best of 2020" Jira Software roundup!

Catch up with Atlassian Product Managers in our 2020 Demo Den round-up! From Advanced Roadmaps to Code in Jira to Next-Gen Workflows, check out the videos below to help up-level your work in the new ...

4,488 views 5 15
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you