Hi guys!
Just migrated Jira 8.22 database from pgSQL 11->13, db connection ok, but upon startup the catalina.out log says:
SEVERE [main] org.apache.catalina.core.StandardService.startInternal Failed to start connector [Connector[HTTP/1.1-8080]]
and nothing is listening on port 8080 (with bad gateway as a result).
netstat -an | grep 8080 confirms that the port is not taken)
I did not touch server.xml, it still says port="8080". Jira changed it by itself, though: reformatted the Connector entry to a single line, and some other minor changes.
One error message (not verbatim): could not create install/work/Catalina/localhost
Changed owner from root to jira, got further but (not verbatim): "cannot parse jira/install/work/catalina.pid". Remove it, touch it, got further permission issues.
I now notice that the catalina.out log says:
18-Apr-2023 12:02:54.284 SEVERE [main] org.apache.catalina.core.StandardService.startInternal Failed to start connector [Connector[HTTP/1.1-8080]]
:
:
Caused by: java.lang.IllegalArgumentException: /home/jira/.keystore (No such file or directory)
at org.apache.tomcat.util.net.AbstractJsseEndpoint.createSSLContext(AbstractJsseEndpoint.java:108)
at org.apache.tomcat.util.net.AbstractJsseEndpoint.initialiseSsl(AbstractJsseEndpoint.java:72)
at org.apache.tomcat.util.net.NioEndpoint.bind(NioEndpoint.java:205)
at org.apache.tomcat.util.net.AbstractEndpoint.bindWithCleanup(AbstractEndpoint.java:1221)
at org.apache.tomcat.util.net.AbstractEndpoint.start(AbstractEndpoint.java:1307)
at org.apache.coyote.AbstractProtocol.start(AbstractProtocol.java:644)
at org.apache.catalina.connector.Connector.startInternal(Connector.java:1137)
I.e. /home/jira/.keystore does not exist... but it never did!
Seems like jira is trying to make an internal SSL connection, but does not have the certificate information...? But hey, it never did!
I'll try to investigate further, but any advice would do!