It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira autostart problem on Debian 9

Hello,

I'm having problem with JIRA autostart on Debian 9.

My Debian 9 instalation iz on VMWare machine, and after rebooting I have to start JIRA manualy with start-jira.sh After manual start everything works fine.

I installed same "atlassian-jira-software-7.4.2-x64.bin" file on another VMWare machine with Debian 8, just to be sure, and it starts automaticly after system reboot.

I used all the sam instalation options on both instalations.

If you need some logs i can provide them.

Thank you in advance

Ivan

1 answer

1 vote

It should have installed startup scripts in /etc/init.d/ but I don't think it flags them for auto-starts them under debian 9.

systemctl | grep -i jira

should tell you the current status, and what the service is called, then you should be able to use

systemctl enable jira.service

Thank you for your reply.

This is what i have in init.d dir:

root@sandbox:/etc/init.d# ls -la | grep jira
-rwxr-xr-x 1 root root 261 Kol 15 10:57 jira

Next command doesn't fetch anything:

root@sandbox:/etc/init.d# systemctl | grep -i jira

When trying to enable service I get next message:

root@sandbox:/etc/init.d# systemctl enable jira.service
jira.service is not a native service, redirecting to systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable jira
update-rc.d: error: jira Default-Start contains no runlevels, aborting.

 

Only mention of jira in my /etc dir is here:

root@sandbox:/etc# find /etc | grep jira
/etc/init.d/jira

Ok, you haven't got a service file and the start script in init.d does not contain what systemctl needs.

This should not be a huge problem.  Ideally, it should be done via systemctl, but I'm not sure how to make that happen and would probably give bad advice.

You can still do it the old way.  Check that /etc/init.d/jira looks like a simple start/restart/stop script that calls your <jira install>/bin/<script> files appropriately, then go to /etc/rc3.d and create a symbolic from there to the init script, so that you have something like

S02jira -> ../init.d/jira

Like # people like this

That worked! :-)

I creted symbolic link in my  rc3.d dir

S02jira -> ../init.d/jira

And now it starts automaticly.

Content od my /etc/init.d/jira file is below:

#!/bin/bash

# JIRA Linux service controller script
cd "/opt/atlassian/jira/bin"

case "$1" in
start)
./start-jira.sh
;;
stop)
./stop-jira.sh
;;
*)
echo "Usage: $0 {start|stop}"
exit 1
;;
esac

Like Harrison Pickett likes this

What is the command to create this symbolic link?

I've done this:

sudo ln -s /etc/init.d/jira /etc/rc3.d/S02jira

It was based on this Ask Ubuntu answer. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Software

How to create Jira issus from Excel file?

When to use CSV importer When managing your processes in Jira, there are many occasions where you need to create a lot of tasks. Creating them one by one will cost you a lot of time and effort and i...

3,744 views 15 27
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you