Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira Server app requires 8.3?

I upgraded from Jira 8.2.3 to Jira 8.3 to take advantage of the new mobile app.

Jira now fails to start, giving the following error...

 

System plugins failed to start: We haven't been able to start all the required system plugins

We couldn't start the following plugins:

 

  • Jira Projects Plugin (com.atlassian.jira.jira-projects-plugin)
  • Atlassian Jira - Plugins - Project Config Plugin (com.atlassian.jira.jira-project-config-plugin)
  • Embedded Gadgets Plugin (com.atlassian.gadgets.embedded)
  • Gadget Directory Plugin (com.atlassian.gadgets.directory)
  • Atlassian Jira - Plugins - Gadgets Plugin (com.atlassian.jira.gadgets)
  • Atlassian Jira - Plugins - Global Issue Navigator (com.atlassian.jira.jira-issue-nav-plugin)
  • Atlassian Pretty URLs Plugin (com.atlassian.prettyurls.atlassian-pretty-urls-plugin)
  • Atlassian JIRA - Plugins - Quick Edit Plugin (com.atlassian.jira.jira-quick-edit-plugin)
  • Atlassian Jira - Plugins - REST Plugin (com.atlassian.jira.rest)
  • Opensocial Plugin (com.atlassian.gadgets.opensocial)
  • Gadget Spec Publisher Plugin (com.atlassian.gadgets.publisher)
  • Gadget Dashboard Plugin (com.atlassian.gadgets.dashboard)
  • Static Assets (CDN) Plugin (com.atlassian.plugins.static-assets-url)

I've tried all the suggested remedies and still get the same problem. Anyone else experience this.

 

FYI, As per the upgrade instructions I performed the upgrade checks and everything was good, and I took a copy of the database before the upgrade. 

2 answers

1 accepted

0 votes
Answer accepted

I noticed an error when using the shutdown script - "wrong Java version". Upgraded Java and now everything works. Not sure why this was an issue - I thought Jira had its own built in JRE. Anyway this seems to have been the issue and now everything is working.  Thanks Pavel for your help.

0 votes
Hi Eamonn,
The problem will be maybe in settings Jira Install folder (or Jira Home folder). You need set all Jira folder to user jira:jira. I think it is now set root:root. After change folder permission, please restart Jira.
Pavel

Thanks I tried that and it made no difference. I even rebooted the server to see if the new file permissions would be an issue - still the same. Thank you for trying to help.

Hi,

OK, your welcome :)

Pavel

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Software

How to create Jira issus from Excel file?

When to use CSV importer When managing your processes in Jira, there are many occasions where you need to create a lot of tasks. Creating them one by one will cost you a lot of time and effort and i...

4,375 views 22 32
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you