JIRA access problem after update

I have a problem after updating Jira from 7.2.* to 7.5.0.

After successfully launching from the command line, it displays messages:

System plugins failed to start: We haven't been able to start all the required system plugins
We couldn't start the following plugins:
Gadget Directory Plugin (com.atlassian.gadgets.directory)
Atlassian JIRA - Plugins - Gadgets Plugin (com.atlassian.jira.gadgets)
Atlassian JIRA - Plugins - Global Issue Navigator (com.atlassian.jira.jira-issue-nav-plugin)
Atlassian JIRA - Plugins - Quick Edit Plugin (com.atlassian.jira.jira-quick-edit-plugin)
Atlassian JIRA - Plugins - REST Plugin (com.atlassian.jira.rest)

I tried resolve problem with this documentation, but failed: https://confluence.atlassian.com/jirakb/troubleshooting-jira-startup-failed-error-394464512.html

Server Java version:

java version "1.8.0_102"
Java(TM) SE Runtime Environment (build 1.8.0_102-b14)
Java HotSpot(TM) Server VM (build 25.102-b14, mixed mode)

My server doesn't have antivirus software.

Regards.

2 answers

Did anyone have a solution for this error? I found that since Jira 7.2x + this error occurs more and more. I have this at least twice a day when I am restarting my test environment. With Jira 6.x I never had such issues.

Have you worked through the troubleshooting doc Mizan pointed to?

Yes I have. I will try to reset the Server, hopefully that will help.

Have you tried restarting JIRA ? 

I had once faced similar issue and just by restarting this was solved.

Seems like a memory issue , may i know if the file system has enough free space and what amount of heap is allocated to JIRA (i.e. the Xmx defined in <installation>/bin/setenv.sh). 

Thank you for answer Mizan,

I restarted the Jira many times, but it didn't work.

I've set parameters seen below in "setenv.sh", and it didn't resolve the issue.

JVM_MINIMUM_MEMORY="1024m"

JVM_MAXIMUM_MEMORY="2048m"

Server parameters:

  • System: 

    Linux srv2 4.4.0-96-generic #119-Ubuntu SMP Tue Sep 12 14:58:51 UTC 2017 i686 i686 i686 GNU/Linux (32bit anyway)

  • Ram: 23.19 GB total / 1.31 GB used
  • CPU: 0.29 (1 min) 0.66 (5 mins) 0.71 (15 mins) (2 processors each 8 cores)
  • Local spaces: 2.10 TB total / 1.98 TB free / 125.81 GB used

Jira has not been updated since 1.5 years. Earlier it works perfectly.

Best regards.

Try increasing the plugin wait time to 300 . (I thought this was fixed but this is still an open issue https://jira.atlassian.com/browse/JRASERVER-60212)

https://confluence.atlassian.com/jirakb/jira-applications-system-plugin-timeout-while-waiting-for-add-ons-to-enable-212173447.html

If this does not work then we need to dig more in the logs. Better create a support case with Atlassian 

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Statuspage

Introducing Statuspage Getting Started guides! First up: What is Statuspage?

Over the next several weeks we'll be sharing some of our Getting Started guides here in the community. Throughout this series of posts, we'd love to hear from customers and non-customers ab...

204 views 4 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you