Issue when deleting a bulk of issues

Dears,

 

please note that the following error problem that i have faced when i tried to delete a bulk of issues:

 

Sorry, we had some technical problems during your last operation.

 

Log's referral number: 464e2c74-3cf2-4bfb-9ceb-8d64a6091d86

Cause

Referer URL: Unknown

java.lang.NullPointerException
1.png

2 answers

0 vote

There is not enough of the underlying error being shown there to begin to diagnose the problem.

You'll need to read the log(<jira home>/logs/atlassian-jira.log) in full to find out what has gone wrong - it should be easy to find the section you need by searching it for the first couple of lines of the detail error in the screenshot.

i know i have tried to attach the log here but unfortunately i couldn't,

You just need to read the section before and after that text.  No-one here is likely to read your entire log for you, but we can't begin to guess at what the problem is without seeing all of the error you've posted.

i have referred back to the LOG, but i couldn't understand where is the error

----

2017-12-31 13:10:12,551 http-nio-8080-exec-6 ERROR      [c.a.j.web.servlet.InternalServerErrorServlet] {errorId=6d60591a-bd18-44b0-af27-136342861d9c, interpretedMsg=, cause=java.lang.StackOverflowError, stacktrace=java.lang.StackOverflowError
        at com.querydsl.sql.SQLSerializer.visit(SQLSerializer.java:849) [querydsl-sql-4.1.4.jar:?]
        at com.querydsl.sql.SQLSerializer.visit(SQLSerializer.java:43) [querydsl-sql-4.1.4.jar:?]
        at com.querydsl.core.types.PathImpl.accept(PathImpl.java:94) [querydsl-core-4.1.4.jar:?]
        at com.querydsl.core.support.SerializerBase.handle(SerializerBase.java:92) [querydsl-core-4.1.4.jar:?]
        at com.querydsl.core.support.SerializerBase.visitOperation(SerializerBase.java:270) [querydsl-core-4.1.4.jar:?]
        at com.querydsl.sql.SQLSerializer.visitOperation(SQLSerializer.java:1006) [querydsl-sql-4.1.4.jar:?]
        at com.querydsl.core.support.SerializerBase.visit(SerializerBase.java:231) [querydsl-core-4.1.4.jar:?]
        at com.querydsl.core.support.SerializerBase.visit(SerializerBase.java:31) [querydsl-core-4.1.4.jar:?]
        at com.querydsl.core.types.OperationImpl.accept(OperationImpl.java:83) [querydsl-core-4.1.4.jar:?]
        at com.querydsl.core.support.SerializerBase.handle(SerializerBase.java:92) [querydsl-core-4.1.4.jar:?]
        at com.querydsl.sql.SQLSerializer.serializeForQuery(SQLSerializer.java:356) [querydsl-sql-4.1.4.jar:?]
        at com.querydsl.sql.SQLTemplates.serialize(SQLTemplates.java:844) [querydsl-sql-4.1.4.jar:?]
        at com.querydsl.sql.SQLSerializer.serialize(SQLSerializer.java:221) [querydsl-sql-4.1.4.jar:?]
        at com.querydsl.sql.ProjectableSQLQuery.serialize(ProjectableSQLQuery.java:490) [querydsl-sql-4.1.4.jar:?]
        at com.querydsl.sql.AbstractSQLQuery.fetch(AbstractSQLQuery.java:429) [querydsl-sql-4.1.4.jar:?]
        at com.atlassian.servicedesk.plugins.approvals.internal.dao.ApprovalDaoImpl.getApprovalsByIssue(ApprovalDaoImpl.java:126) [?:?]
        at com.atlassian.servicedesk.plugins.approvals.internal.approval.ApprovalManagerImpl.lambda$getApprovalsByIssue$4(ApprovalManagerImpl.java:119) [?:?]
        at com.atlassian.pocketknife.internal.querydsl.DatabaseAccessorImpl.lambda$execute$0(DatabaseAccessorImpl.java:69) [?:?]
        at com.atlassian.sal.core.rdbms.DefaultTransactionalExecutor.executeInternal(DefaultTransactionalExecutor.java:86) [?:?]
        at com.atlassian.sal.core.rdbms.DefaultTransactionalExecutor.lambda$execute$0(DefaultTransactionalExecutor.java:42) [?:?]
        at com.atlassian.jira.database.DatabaseAccessorImpl.runInManagedTransaction(DatabaseAccessorImpl.java:125) [classes/:?]
        at sun.reflect.GeneratedMethodAccessor264.invoke(Unknown Source) [?:?]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [?:1.8.0_102]
        at java.lang.reflect.Method.invoke(Method.java:498) [?:1.8.0_102]
        at com.atlassian.plugin.util.ContextClassLoaderSettingInvocationHandler.invoke(ContextClassLoaderSettingInvocationHandler.java:26) [atlassian-plugins-core-4.5.0.jar:?]
        at com.sun.proxy.$Proxy246.runInManagedTransaction(Unknown Source) [?:?]
        at sun.reflect.GeneratedMethodAccessor264.invoke(Unknown Source) [?:?]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [?:1.8.0_102]
        at java.lang.reflect.Method.invoke(Method.java:498) [?:1.8.0_102]
        at com.atlassian.plugin.osgi.bridge.external.HostComponentFactoryBean$DynamicServiceInvocationHandler.invoke(HostComponentFactoryBean.java:136) [?:?]
        at com.sun.proxy.$Proxy246.runInManagedTransaction(Unknown Source) [?:?]
        at com.atlassian.sal.jira.rdbms.JiraHostConnectionAccessor.runInStartedOrExistingTransaction(JiraHostConnectionAccessor.java:130) [?:?]

---

Ohh, that's not going to be nice.

A stack overflow error means Java ran out of memory space.  This is not a case of giving it more memory though, the error is most likely to be caused by recursion - code calling itself inside itself, and increasing memory just means it'll crash a little bit later.

I think this is one that needs to go to Atlassian support, as it's something in the Service Desk application causing the recursion to happen.  I'd ask https://support.atlassian.com/contact

0 vote

Hi @Basem Qreieyeh,

 

Did you open a ticket with support about this? Is the issue solved?

Also, not sure it can help, but a similar stacktrace is found in: https://github.com/everit-org/jira-timetracker-plugin/issues/465 

 

In there they say the following but I am not sure this has the same cause. Having ticket with support will give us the opportunity to investigate further:

We finally identified the root cause of this error. The issue quantity does matter, but not the number of issues in the query, but generally in the JIRA (or in the affected projects).
We use a different query in the webform and for the filters, but we will fix this in the near future.
Thank you for your report and for your patience!

Thank you for your interest i have setup a new environment,

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 21, 2018 in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

1,221 views 10 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you