Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,361,824
Community Members
 
Community Events
168
Community Groups

Issue Flagging just stopped working

I have been using flags for a while in both automations and manually and have had no problem. I went on vacation and came back and it's not working any more. It's broken in a couple of different ways:

  1. I get an error if I try to manually flag a ticket from the more (...) menu that says "We couldn't flag this issue. Check your connection and try adding the flag again." My connection isn't an issue. I can edit and update anything else on that ticket just fine. 
  2. My automation that sets Flagged to TRUE when I move a ticket into a specific status works but cards aren't getting colored yellow on the boards like they should be when they're flagged. I see the Flagged icon on the card though.

It's MADDENING! Anyone know why this is happening all of a sudden? I've checked my field config and it's enabled there. 

2 answers

1 accepted

1 vote
Answer accepted

Hi @Kathy Barton 

I just tried this:

  • manually with company-managed and team-managed projects and flagging worked;
  • tried it with my automation rules and those worked; and
  • checked the REST API, and the flagged and unflagged issues returned as expected.

I see nothing on the Atlassian status page for this symptom, so perhaps consider asking your site admin to submit a support ticket to see if they notice anything in their logs.

Kind regards,
Bill

Thanks! I just found out this is broken site wide and we already have an open support ticket. 

Like Bill Sheboy likes this

FYI It turned out that a bad migration step created multiple contexts for the Flagged column that were conflicting with each other. We had to delete them all to get this problem to go away. 

Yikes!  I am glad to learn you figured it out and resolved it.

__Bill

We seem to have the same problem after migrating from server to cloud (I was not involved in the migration) but how can I find the steps that needs deleting? 

I have a same issue @Kathy Barton  Could you please share how did you clean up?

Like # people like this

@Kathy Barton  Could you please share how to fix/clean up this issue

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Software

An update on Jira Software customer feedback – June 2022

Hello Atlassian Community! Feedback from customers like you has helped us shape and improve Jira Software. As Head of Product, Jira Software, I wanted to take this opportunity to share an update on...

5,082 views 18 32
Read article

Atlassian Community Events