Installed Jira and Confluence as a service, but they don't start on startup

I have installed Jira, Confluence, and Bitbucket servers on a Ubuntu server. I have installed them all as services and selected that they should startup automatically. 

Bitbucket starts on startup, but Jira and Confluence do not. I have had a bit of a look as to why, but I can't seem to find any clear help for this

1 answer

0 votes

If you try

systemctl enable jira

systemctl start jira

what do you get?  If it fails, it should give you a bit more info about why (although it can be quite cryptic).  If that appears to work, then it's likely to have run the startup scripts.

However, I also suspect the installers for Jira and Confluence are a bit behind the ones for bitbucket - I guess you might just get "unknown service" because they've only created /etc/init.d scripts, rather than systemd services.  If that's the case, I don't actually know what the best thing to do is (but I created service files for them that pointed to the /etc/init.d scripts, which seems to work fine)

I get an error when running the enable command.

Jira.service is not a native service, redirecting to systemd-sysv-install. 

Executing: /lib/systemd/systemd-sysv-install enable jira

update-rc.d: error: jira Default-Start contains no runlevels, aborting.

Same when trying for confluence

Ok, that's what I expected from "no systemd install".   If you want to fix this the way have, this may help.  Create the file, adjust it for your install and re-try the enable.

 

root@zen:/etc# cat systemd/system/jira.service
[Unit]
Description=JIRA Service
After=network.target

[Service]
Type=forking
User=jirauser
#Environment=JRE_HOME=/usr/java/jdk1.8.0_74
ExecStart=/opt/jira/bin/start-jira.sh
ExecStop=/opt/jira/bin/stop-jira.sh
ExecReload=/opt/jira/bin/stop-jira.sh | sleep 60 | /opt/jira/bin/start-jira.sh

[Install]

WantedBy=multi-user.target

Like 1 person likes this

That worked for Jira, it seems, although I'll find out for sure when I restart.

Doing the same but for confluence, I got:

Synchronising state of confluence.service with SysV service script with /lib/systemd/systemd-sysv-intstall.

Executing: /lib/systemd/systemd-sysv-install enable confluence

update-rc.d: error: confluence Default-Start contains no runlevels, aborting.

Odd, I'd expect the same from the Jira service.  Have a look at the top of the start-jira.sh and start-confluence.sh files - do they have lines like

### BEGIN INIT INFO
# Provides:          jira
# Required-Start:    $all
# Required-Stop:
# Default-Start:     2 3 4 5
# Default-Stop:
# Short-Description: Jira
### END INIT INFO

No, neither do. The main difference was when doing the systemctl enable jira it said something about creating a symlink with another file (I didn't note it down). It didn't read the same for confluence.

Also, my jira service if started through service command is jira1 and the user is jira1. But obviously that hasn't mattered as jira seems to work and confluence doesn't (with systemctl at least). 

Running as jira1 is fine, it just means the installer detected a user called jira already and didn't re-use it (because it may be from a failed or removed previous install, or have been created differently, and it doesn't know if it's suitable)

The creation of a symbolic link is normal, it's systemd creating the startup link to the file its going to run.

The Confluence one is going to be harder, I don't know why it's not working when Jira does, they're not that different. 

Do you have the /etc/init.d/confluence.sh script?  Does it start confluence ok when run standalone?

After creating a proper systemd unit file as suggested by @Nic Brough [Adaptavist]

sudo vim /etc/systemd/system/jira.service

[Unit]
Description=Atlassian JIRA Software Server
After=network.target postgresql.service

[Service]
Type=forking
User=jira
ExecStart=/opt/atlassian/jira/bin/start-jira.sh
ExecStop=/opt/atlassian/jira/bin/stop-jira.sh
ExecReload=/opt/atlassian/jira/bin/start-jira.sh | sleep 60 | /opt/atlassian/jira/bin/stop-jira.sh

[Install]
WantedBy=multi-user.target

i got the same error as @Joe Fenton

sudo systemctl enable jira

Synchronizing state of jira.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable jira
update-rc.d: error: jira Default-Start contains no runlevels, aborting.

I fixed that by removing that legacy SysV script:

sudo rm /etc/init.d/jira
sudo systemctl enable jira

Same fix for confluence.

Like 2 people like this

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Feb 26, 2019 in Jira Software

How to prevent the propagation of unused project schemes, workflows & screens in Jira software

Atlassian ranks project attributes as the third most important factor impacting performance in the category of data. It’s not surprising, since project attributes are precisely the rules used to ma...

628 views 0 7
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you