Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Incoming Mail Settings Error - SunCertPathBuilderException

Hello,

I'm running into this issue while configuring Incoming Email with secure_pop in JIRA. Any workaround for this issue? I'm getting below error;

Note: I already added certificate to keystore in JIRA, and i can see on page SSL. This certificate same with Exchange server. and generated from Comodo.

Error;

Unfortunately no connection was possible. Review the errors below and rectify:

  • SunCertPathBuilderException: unable to find valid certification path to requested target

Best,

Enes

 

1 answer

@Ismailcan Sezer 

Hi Ismailcan

 

welcome to the Atlassian community.

Can you verify that the added entry in your keystore is correct. You can use the SSLPoke class provided at https://confluence.atlassian.com/kb/unable-to-connect-to-ssl-services-due-to-pkix-path-building-failed-error-779355358.html to double check that

 

All the best

 

Kurt

Hi Kurt,

i verified keystore its seems correct, and SSLPoke class result is Successfully connected on Jira and Exchange server. But issue still exist.

Java version is : jre1.8.0_121 

Best

Ismailcan

Hi Ismailcan

 

i assume you did restart your Jira instance after you modified the keystore - right?

 

Is the Java binary that you use to run SSLPoke, the same that Jira uses?

Are there any alternative keystores defined?

 

Cheers

 

Kurt

Yes, restarted server after modified. 

How can i check which java use in Jira? In Windows server Java_Home folder is C:\ProgramFiles\Java\jre1.8.0_121 but in Jira JRE folder is different. I already imported trust certificate to both folder lib\security\cacerts file. 

And keystore path is : C:\Program Files\Atlassian\JIRA\jira.jks , i was configured for HTTPS WebServer. 

Best

i tried to changed keystore path with \Atlassian\Jira\jre\lib\security\cacerts file, and imported to in trusted certificate and key pair but still same problem exists. 

also i tried to changed Java_Home path with \Atlassian\JIRA\jre.

After all i have done i restart Services, and SSLPoke test seems to be successfull.

@Ismailcan Sezer 

 

Sorry for my late response.

Just to double check, the ssl certs have been added to the keystore that is referenced in the jira configuration and if you run the sslpoke test with that store and the corersponding java binary it works - right?

 

Cheers

Kurt

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Software

Presenting the "Best of 2020" Jira Software roundup!

Catch up with Atlassian Product Managers in our 2020 Demo Den round-up! From Advanced Roadmaps to Code in Jira to Next-Gen Workflows, check out the videos below to help up-level your work in the new ...

7,022 views 8 28
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you