Importing from another backup

I have a database that was backed up for 6.4.10 and tried to follow the instructions to import this into my test 7.4.0 environment (https://confluence.atlassian.com/jira064/restoring-a-project-from-backup-720412082.html) but the system continues to crash and hose up my dev enironment. See following error message:

Error importing data: org.xml.sax.SAXException: com.atlassian.jira.exception.DataAccessException: org.ofbiz.core.entity.GenericEntityException: while inserting: [GenericEntity:Action][updateauthor,bboulger][issue,10782][author,bboulger][created,2012-01-03 16:23:05.0][id,11880][type,comment][body, From: Garvin, Bob Sent: Tuesday, January 03, 2012 4:13 PM To: Boulger, Billy; Crone, Christopher; Collier, Matthew; Karnik, Gautham Subject: FW: Genzyme (Ireland), PAT700's, Power Reset FYI (see customer response below). From: Morrow, Ian [mailto:ian.morrow@hach-lange.co.uk] Sent: Tuesday, January 03, 2012 3:52 PM To: Garvin, Bob Subject: FW: Genzyme (Ireland), PAT700's, Power Reset Hi Bob, Completed information from Genzyme. Please note that we have had another power failure on the 25th December. Any thoughts before I call in on Thursday please touch base with me. Thanks Ian Morrow Regional Sales Manager Ireland Life Science Division HACH LANGE LTD Unit 1 Chesnut Road, Western Industrial Estate Dublin 12 Tel. +353(1) 4602522 Mobile Tel: +353 (0) 879293905 Fax +353 (0) 4509337 Info@hach-lange.ie www.hach-lange.ie <http://www.hach-lange.ie> Visit www.hach.com/HUA <http://www.hach.com/HUA> for all product brands! Visit www.hach.com/HIAC <http://www.hach.com/HIAC> for the new HIAC Product! Visit www.hach.com/METONE <http://www.hach.com/METONE> for the new METONEProduct! Visit www.hach.com/ANATEL <http://www.hach.com/ANATEL> for the new ANATEL Product! Visit www.hach.com/ISO21501 <http://www.hach.com/ISO21501> for the latest regulatory compliance information! ________________________________ From: Long, Kevin GZ/IE/EXT [mailto:Kevin.Long@genzyme.com] Sent: 03 January 2012 18:46 To: Morrow, Ian Subject: FW: Genzyme (Ireland), PAT700's, Power Reset Hi Ian, I entered information (in red) into Bob's table below. I've attached the data log for the most recent power failure which ocured on 25th Dec 11 at 01:08. In relation to Bob's question: ...... 17:41 3.3 1 0.0 0.66 26.4 P2 17:45 3.3 1 0.0 0.66 26.4 P2 17:49 ?0000 3.3 1 0.0 0.67 26.4 P2 17:53 3.3 1 0.0 0.67 26.4 P2 17:57 3.3 1 0.0 0.67 26.4 P2 18:01 3.3 1 0.0 0.67 26.5 P2 18:05 3.3 1 0.0 0.67 26.5 P2 18:09 3.3 1 0.0 0.67 26.5 P2 18:14 3.4 1 0.1 0.67 26.5 P2 18:17 3.3 1 0.0 0.67 26.5 P2 18:22 3.3 1 0.0 0.67 26.6 P2 18:26 3.3 1 0.0 0.67 26.6 P2 18:30 3.3 1 0.0 0.67 26.6 P2 18:34 3.4 1 0.1 0.67 26.6 P2 CRC: 0x8F33][updated,2012-01-03 16:23:05.0] (SQL Exception while executing the following:INSERT INTO public.jiraaction (ID, issueid, AUTHOR, actiontype, actionlevel, rolelevel, actionbody, CREATED, UPDATEAUTHOR, UPDATED, actionnum) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?) (ERROR: invalid byte sequence for encoding "UTF8": 0x00))

1 answer

0 vote

I think you missed something in the documentation - you can only import from the same version data.  6 to 7 won't work directly, you need to takethe 6 data and upgrade it to 7, then export it.

I created a Jira instance with 6.4.1 and tried the import and it gave me the same error.

Ok, are you changing databases with this import?

This was exported from another server. So, this is being added to a whole new system that I built.

That's not what I asked.  Are you changing the underlying database?  e.g. the source was Oracle and you are importing into PostGreSQL?

I just found out that the system was running on Windows Server 2008 with mysql 5.6.36 as the database system. Jave 1.8.0_51 with tomcat 7.0.55

My current instance is Windows Server 2012 R2 running PostgreSQL 9.6

Ok, so there is a database migration here as well.

That does not really affect the answer though, as you are using the xml exports.  You need to take the full export, import it into another system on the same version (but not necessarily the same database - the xml export handles that, as it is database agnostic), then upgrade it to the target version, and export from there.

Suggest an answer

Log in or Join to answer
Community showcase
Emilee Spencer
Published yesterday in Marketplace Apps

Marketplace Spotlight: DeepAffects

Hello Atlassian Community! My name is Emilee, and I’m a Product Marketing Manager for the Marketplace team. Starting with this post, I'm kicking off a monthly series of Spotlights to highlight Ma...

50 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot