How to recover access to a project?

I was trying to build a mockup project to pitch JIRA for a broader use and when I created a new user he had access to three projects instead of only the mockup I created.

I went to the other two settings and on permissions on the "Browse Projects" permission I removed the "Application Access (anyone logged)" item.

After that even I, as administrator, can´t access those projects. I see them on my project list but when I click on them it says I don´t have permission to access it.

After that the newly created user can´t see anything at all not even the mockup. As if I changed a template that affects all or something.

How can I recover access to these projects!?

Thank you in advance

1 answer

1 accepted

This widget could not be displayed.

Hi Nuno,

add yourself (or the jira-administrators - role) to the permission schemes of your projects with your administration forms:

http://<your jira-url>/secure/admin/ViewPermissionSchemes.jspa

Hi Thomas, thank you for your fast and accurate answer. But it's not 100% solved :(

I change the main template to the original setting where the "Browse Project" is available for all logged users. And then changed two of them from "Default Software Scheme" to "Default Permission Scheme" 

I can now access one of the two previously lost but the one where I originaly had made the change gives me the message

"This project isn't available

It may have been deleted or your permissions may have changed."

 

It has exactly the same permissions template as my other functional projects. 

The new project under "Default Software Scheme" is also ok.

Any pointers for this?

Thomas Schlegel Community Champion Jan 22, 2018
  • Did you change every permission scheme?
  • Do you see your project in the view http://<your-jira-url>/secure/admin/ViewPermissionSchemes.jspa ?
  • If you see your project, please click on the "Permissions" - Link and verify that you changed the "Browse Projects" Permission

Think of the permission scheme as the set of rules that define access, not the whole access setup.

Have a look at the rule for "browse project", it probably says something like "Browse project:  Role (Users)".  You need to make your account match that rule, so for this one, use your admin rights to go to the project admin and make sure the right people are in the role of "Users" in the "people" section.

All solved! Thanks!
I'll share details below.

@Thomas Schlegel

  • Did you change every permission scheme?
    • I only had changed the "Browse Projects" on "Default Software Scheme", the project is now on the "Default Permission Scheme" where "Browse Projects" is unchanged as "Project Role" = Users+atlassian-addons-project-access, which works fine for every other projects using the same Scheme. Only the project where I had made the change before moving to this scheme is crashed, the other 8 using "Default Permission Scheme" are fine.

  • Do you see your project in the view http://<your-jira-url>/secure/admin/ViewPermissionSchemes.jspa ?
    • Yes, I see it, under "Default Permission Scheme"

 

@Nic Brough [Adaptavist]

I am in the "User" group as well as in the "Administrators" group. 

Following your lead I went to check the People on the Project, from the permissions schemes admin page,  and the group Administrators was only with role "Developers", I added the role "Users" and all went ok.

Moving it from scheme created the inconsistency, although logically being a developer should be an upgrade from being an user.

I learned my bit!


Suggest an answer

Log in or Sign up to answer
Community showcase
Published Apr 22, 2018 in Jira Software

How-to setup a secured Jira Software 7.9.0 on Ubuntu 16.04.4 in less than 30 minutes

...PermissionsStartOnly=true User=www-data Group=www-data ExecStart=/opt/jira/bin/startup.sh ExecStop=/opt/jira/bin/shutdown.sh TimeoutStartSec=120 TimeoutStopSec=600 PrivateTmp=true [Install] WantedBy...

1,462 views 10 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you