How to disable detection of browser language?

Andrey Kovalenko August 8, 2018

I want JIRA to show all its content in English, no matter which language my browser uses.

I have changed default language to English, my profile's language in English, but when I open JIRA with my browser, I see all content in the language of my browser.

No doubt JIRA is a very clever program, but why pretend it is much more clever than it actually is?

So, how do I force JIRA to show all its content in default language (and only in default language)?


Thank you!

2 answers

4 votes
Francesco Vitrani April 18, 2020

I solved the issue by changing the language to English in the account preferences (not only in the Jira settings).

Go to:

...and set language to English. That should do the trick.

0 votes
Angélica Luz
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
August 20, 2018

Hi Andrey,

It's not possible to disable the translation on Jira, because this functionality is only on the browser and not on Jira.
If you already set the default language on System > General configuration and also set your profile language to English, if Jira is being translated is due to the browser.

It's possible to disable the translation directly on your browser, so this issue will not happen anymore. 


Andrey Kovalenko August 22, 2018

Hi Angélica,

Thank you for the answer.

With all respect, would you please allow me to raise an objection.

>>> because this functionality is only on the browser and not on Jira.

Browser itself doesn't produce any content. It is not capable to translate anything by itself. It is JIRA who sends the content in response to the browser's request.

And yes, it is the browser who says "I would like to receive content in <some_language> if possible". It is the browser's "Accept-Language" header responsible for that behavior.

I can download a Chrome extension which will suppress this header and therefore force JIRA website give me the content in the language I prefer by default (English).

Also, I can delete all supported languages but English in my JIRA cloud installation.

But why on green Earth would I do all the nonsense mentioned above? Why not to provide the possibility to say JIRA "English, *******, do you speak it???"

The product Atlassian has acquired recently, Trello, does provide such a possibility.

Why JIRA wouldn't then?

Like Sasha Saminsky likes this
Angélica Luz
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
August 27, 2018

Hi Andrey,

Thank you for the details and I apologize for the confusion.
I've tested using Google Chrome in English and my Jira in Portuguese, but Chrome didn't translate Jira.
So, for us to test the same behaviour, can you please tell us what browser are you using? What is the browser version?
We need this details to check if it's happening with a specific browser.
Also, please send us the steps to reproduce and what screens are being translated.


Avinomics-Admin (S.Herrmann) October 12, 2018

We have the same problem in our company. Jira Cloud mixes German and English language, even though I configured Jira to use English only. The problem persists, no matter which browser I use (tried Firefox, Chrome, IE). Very annoying and unacceptable for an enterprise level product.

Like # people like this
Angel February 9, 2019

Same problem here. Jira set in English, but all content in Spanish (Chrome 72)

Nhan.Thai February 27, 2019

Hi @AlL

I had the same issue but resolved by changing the config of order languages. So you can check and config by this screenshot.



Like # people like this
Keven Perreault October 30, 2019

Thank you, you just solved my problem, any idea how to deploy this to everyone ?

Rafael_Nobre December 11, 2019

This began happening a few days ago in my system. No browser change, no language set to translate in Chrome. Tested on Safari as well with the same behavior.

Actually my system is in English, I don't know why Jira is trying to be smart about my language.

Like Gijs P likes this
Mirko Flyktman December 11, 2019

I am having the same issue as Rafael, I can't change my JIRA language away from Finnish. My browser is changed to have only English as a language, and I changed my Atlassian profile language into English. This is annoying since Finnish is quite bad as "development language".

Like Gijs P likes this
mutiev January 17, 2020

Also have the same problem. I have english version of ubuntu, already changed language in settings of chrome to set language with highest priority as english, but jira still translates in russian and it don't care about my user preferences

Dear Atlassian, this is bad feature :)

Like Faber Aristizabal likes this
Jan_Mateboer February 6, 2020

Same problem here, I changed Jira language to english (both for tickets and display), deleted all other languages in my browser except english, disabled the 'offer translate' option, still it translates the page to local language (which is unreadable for my clients).

I can briefly see it appear in english but within a second it switches to local translation (which is also not very accurate). Also when visiting any other page in the same browser it does not translate pages, so apparently Jira/atlassian is forcing it to translate anyway. Tried both Chrome and Edge.

I suspect it actually IS Jira doing the translating because only part of the website is translated, not custom issue titles, labels configurations or text.

Rafa March 18, 2024

This is absurd..

As an admin, it should be possible to disable certain languages and to set the UI for users in a certain language. (just because an employee uses their computer in French, if the company's language is in English they should use Jira in English and not get "TO DO" translated automagically to French as it causes confusion when talking with other people in the organization).

Jira is such a weird platform. It makes complex use cases possible, and it makes simple use cases complicated and complex.


Like Henrik Gullvén likes this

Suggest an answer

Log in or Sign up to answer