Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to add alies to an URL type customfield Edited

I have a URL typed customfield, and I have a very long URL, so I want to add an alias to it.

 

I cannot change the renderer for URL type customfield so, I created a Text Field and I changed the Renderer to Wiki Style Renderer.

 

The format that I tried: [LINK|https://someurl.com] but it isn't working that I expected.

I want to see in my customfield just a LINK label, which is a hyperlink, but I cannot manage to solve this problem with a text field and with an URL field too.

 

What am I doing wrong? 

image.png

2 answers

0 votes
Prince Nyeche Community Leader Jan 08, 2021

Hi @Erdős Zoltán 

Use markdown instead not Wiki style on the new issue view.

[LINK](https://someurl.com)

It doesn't work neither.
I tried with an extra space between it, but not helped. 

The link is not working too in this case.

I tried with

 

image.png

Prince Nyeche Community Leader Jan 08, 2021

Hi @Erdős Zoltán 

It seems markdown doesn't work on Text Field (single line), you have to use multi-line Text Field for it to work and ensure you add the custom field on the context field of your issue layout. E.g below is an example I did, with Custom field "Test Multiline"

field.png

Like Erdős Zoltán likes this

There is bug in our cloud jira I think:



I just did what you recommended, and I typed both of the format solution into a multine text field:

image.png

 

When I press F5 in Chrome browser, it appers correctly in the second solution in multiline text customfield, but at the moment, that the page fully loaded, the formatting is gone again. Very strange, but I tested again and again.

image.png

So it is working for 1 sec, until the page fully loaded. 

Daniel Ebers Community Leader Jan 09, 2021

I was able to reproduce your issue, so it is not just a bug of your cloud instance.
The "1 second" visibility until the link is displayed wrong also happens in Mozilla Firefox.

I was NOT able to put in a working link in multi-line field Text Field like Prince successfully did.

Also the links in description only work reliable when using the "link" icon. All said above referring to New Issue View.

Using

[LINK](https://someurl.com)

the link URL appears for a second as a clickable link but formatting stays alongside with URL - that was not desired.

Using

[LINK|https://someurl.com]

the perfect link appears for a second then comes back to a non-clickable [LINK|https://someurl.com] at all

Prince Nyeche Community Leader Jan 11, 2021

Hi @Erdős Zoltán 

I think it's important you add the Multi-line text field into your Context fields in your Issue layout. Project settings > issue layout > context fields drop the field there.

Likewise, if you already have Wiki renderer on the field, you can easily use the WYSIWYG editor (Rich text editor) and simply add a Link by using the Link icon after highlight the text "LINK" without even using markdown. 

Hi,

 

I put it into context fields, the result is same again. 

 

image.png

0 votes

Hi @Erdős Zoltán

please disregard my previous message. It turned out the field was not set to "Wiki Style Renderer" which, of course, you stated in your instance it is.

In the last step of changing the renderer there is a warning message which I almost missed to confirm.

That leads to the assumption the Renderer for the field you are using is not set correctly - the behaviour one encounters when this is the case is exactly the same that I had in my Cloud instance.

Could you please double check and confirm? If this does not help could you please assist with a couple of screenhots?

Here the exact format that was used:
[My important link](https://example.com)

Many thanks for your patience!

Cheers,
Daniel

Dear Daniel,

 

Thank you for helping me. 

 

I triple checked it, and I use MultiLine Text field with Wiki Style Renderer, as the screenshot prove it. 

Still works for 1 second, and after that, it will be plain text again. 

image.png

Daniel Ebers Community Leader Jan 10, 2021

Two things I found out:
1.) it seems to make a difference if the link is type in (character by character, a human per keyboard) OR if copy&pasted in.
By typing in I had a success.

2.) It seems to work more reliable when put to "Context fields" (the part on the right hand)
https://support.atlassian.com/jira-service-management-cloud/docs/what-are-the-different-sections-in-the-issue-view/

I put it into context fields, the result is same. It works only for 1 sec. :(

Daniel Ebers Community Leader Jan 11, 2021

Does it work if you type in the link alongside with the proper syntax of: [My important link](https://example.com) ?

Shoud I see a wysiwyg editor when I click into that multiline field?
It has a plain multiline text editor, I cannot see a LINK button or anything else like in the description field...

Daniel Ebers Community Leader Jan 11, 2021

Yes, it should appear indeed when the Wikistyle Renderer is set for the field correctly.
In my case it appeared after doing so - but as I said for the first attempts I missed doing so while I also had to test a bit around.

If it not appears I assume there is still missing a setting (did you really look into the appropriate Field Configuration/"is the Field Configuration scheme assigned to the project correctly?") or something really strange is going on.

Yeah, I think all of my screenshot prove that I did what I should. I have no idea, what I missed. I will rechek it again and again I think.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Trello

📹 Favorite Trello templates

Hello Community!  My name is Brittany Joiner and I am a Trello enthusiast and Atlassian Community Leader. In this video, I'll share my favorite Trello templates. Templates mentioned in ...

75 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you