Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How do I use email handlers to strip out the comment only from an emailed reply?

When a reporter replies to a Jira Software email notification, the entire email and original notification is added to the ticket as a comment.

Is it possible to strip out the new comment only so that the notification and everything else under the quoted email is ignored (and not duplicated).

I've been reading the help but can't figure out what I need to change in the setup below.

Mail Handlers

The table below shows the mail handlers currently configured for Jira.

Handler Name / Type



Issue Type


Comments from emails

Cloud Email Handler

Default Cloud Mail Server



Bulk: ignore

Create Users: false

Strip Quotes: true


Create issues or comments

Create a new issue or add a comment to an existing issue

Default Cloud Mail Server

Project Name


Bulk: ignore

CC Assignee: true

CC Watchers: false

Create Users: false

Notify Users: true

Strip Quotes: true



1 answer

1 accepted

0 votes
Answer accepted

Hello @Nigel Adams

Sorry to hear you are facing this problem.

Checking your E-mail handler settings, It seems to be properly configured to skip the previous notification content from the comment added (Strip Quotes = True).

That being said, please follow the steps below so we can better troubleshoot the issue:

1 - Is this problem happening when a default software user adds the comment or is it happening for JIRA Service Desk customers? If you are using Service Desk, check under Jira settings > Products > Email requests if the Strip Quotes option is flagged.

2 - Can you please confirm if the commenter is using an Outlook e-mail account to add the comments? As you can see in the feature request below, Outlook has a feature that you can select NonQuotedCommentHandler and CreateOrCommentHandler, causing the "old" messages to don't be stripped out:

Better support for reply emails from Outlook by mail handlers

if you are facing this scenario, the workaround available would be to change the configuration of each Outlook client like described in this Documentation or use a different client to use JIRA. Also, feel free to vote and watch the suggestion to increase its priority and also receive notifications about any updates.

Let me know if this information helps.

hi @Petter Gonçalves 

I have a similar issue where incoming messages are failing due to the comment being too long.

I've confirmed that "strip quotes" is enabled, but it appears that the entire email message is being put into the comment which results in a failure.


Are there any other recommendations you might have?


Thank you!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Confluence Cloud

🎨 Add some visual life to your templates

Hi Atlassian Community, My name is Avni Barman, and I am a Product Manager on the Confluence Cloud team. Based on feedback from you, we are giving admins more power to create templates that a...

184 views 3 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you