Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How do I add start/due dates to my epics and how do i make them show on Roadmap?

I have created some epics in the Roadmap section of Jira but they are not showing. After creating the epic in Roadmap a message popped up stating that my epics are not showing because it doesn’t match my board filter. 

The epics can be found in Issues and Backlog but not on roadmap. Also, I am unable to add start and due dates. 

 

Could this be a permissions issue I need to contact my administrator for? 

Looking forward to hearing from someone.

1 answer

1 vote
Mykenna Cepek Community Leader Jun 17, 2021

The message you got is the best hint about what's likely wrong: the underlying Filter.

In the Roadmap, go to the "Gear menu > Configure" and see what's shown under "Source data > Issue sources". Here you can select one or more Projects, Filters, or Boards. For whatever is shown, track down the actual Filter being used (which may be set within a Project or for a Board). You'll likely find that the JQL for that filter does some selection based on Issue Type.

You can either adjust the "Issue source" for your Roadmap (to use a different filter or board related to that project), or you may need to create a new filter without that issue type exclusion.

I don't think you need to worry about permissions in this case (for being able to see Epics). However, if you don't have permission to edit the Roadmap, then you may be prevented from performing the remedies I suggest here.
_ _ _ _ _ _ _

Once the filter is correct for the Roadmap, there are still several things that might prevent you from seeing Epics:

Check that the Hierarchy is set to display Epics. If the first option isn't set to "Epic", then they won't show in the Roadmap display:

one.png

If that doesn't fix it, confirm that you aren't filtering on Issue Types:

two.png

Another possibilitity is under "Gear menu > Source data > Exclusion rules", where you can inspect the "Exclude issue types" field.

Much less likely is that Epics were manually excluded from the plan. Check this under "Gear menu > Source data > Removed issues". You can "Re-include" issues that were excluded (but it may surprise other users of the Roadmap).

Thank you very much for your suggested resolutions. The problem is I don't seem to have the permission to edit roadmap. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Trello

🏊‍♀️ Atlympic Event: Trello

Hello Community!  Quick disclaimer: We are running a contest on Community (The Atlympics!) from July 23rd - August 8th of 2021. If you are interested in participating in this contest (prizes! ...

99 views 1 10
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you