Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,323,862
Community Members
 
Community Events
168
Community Groups

Fix Version field disappears

I am writing stories for an Epic and do not have the option to set the Fix Version. When I go to configure the issue layout, I have moved Fix Version from Hide When Empty to the context fields, and while the page is loading it is visible, however, when the page fully loads the option disappears. I am unable to set the fix version for either a story or the Epic. 

 

Again, the Fix Version field shows while the page is loading (blue bar along the top of the screen), but once fully loaded it disappears. 

 

Screenshots are below showing the page loaded without the Fiv Version option, and while the page is loading, still displaying the Fix Version option. 

loaded.pngloading.png

2 answers

1 vote

Hello @John Maner ,

Thanks for the info and this looks like a new Bug. 

I can reproduce the behavior if the user viewing the request does not have the resolve issue Project Level Permission.  So currently the only workaround I could come up with would be to grant the project permission to any user that requires visibility of the field when empty, however, do note that the field is populating once a value is set for the field so only users that cannot set the field cannot see the field when empty.

Basically, the Field is hidden when empty for users that do not have permission to set a value for that field but does display when empty for users that do have permissions set to update the version.

I created a Bug Report at the following link to track the issue, can you double-check and verify this lines up with what you are seeing:

Regards,
Earl

hello @Earl McCutcheon 

we have the same issue here. but the fixVersion only disappeared on bug issue type (create screen). please be informed that create screen is the same as edit and view screen. i have checked everyone has Resolved Issue permission. i think this issue started to happen after we updated to jira version to 8.12.0. before this we were in version 7.12.3

Hi @didi

Please grant close issue permission to the user the issue will be resolved . 

I had the same error and solved it after doing this:

On the issue press the three dots (...) -> Find your field -> type the name of the field and Jira will suggest what to do to show it! It's easy... although I learn this after 01 hour checking the config of the screens/fields 

I was also faced same issue on JIRA 8.20v DC environment. After investigation, found that it was disappear because of Resolved issue permission. This permission will allow you to set fix version for the issue. 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
TAGS
Community showcase
Published in Jira Software

An update on Jira Software customer feedback – June 2022

Hello Atlassian Community! Feedback from customers like you has helped us shape and improve Jira Software. As Head of Product, Jira Software, I wanted to take this opportunity to share an update on...

2,538 views 6 22
Read article

Atlassian Community Events