Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,364,916
Community Members
 
Community Events
168
Community Groups

Fatal Error during import of Task and related Sub-task

I have created a very simple test load file for bulk loading Tasks and sub-tasks as per the Import data from a CSV instructions.

I have:

Issue ID, Parent ID, Issue Type

1,,Task

,1,Sub-task

I have mapped the Issue ID to Issue ID in the import config

and Parent ID to Parent ID in the import config

When I load I get a fatal error advising that Parent can't be NULL, but it is not NULL.

I have previously validated all of the other values  to be loaded with no errors so it is not a rogue validation error.

How can I resolve this problem please?

2 answers

1 accepted

0 votes
Answer accepted

Actually found this article, so the solution is load parent then load child.

 

https://confluence.atlassian.com/jirakb/csv-import-parent-child-mapping-1096095688.html

0 votes

Welcome to the Atlassian Community!

Your file looks technically correct to me, but I have a nagging doubt that it doesn't like the empty issue id on the sub-task line.  

When I do imports with sub-tasks, I've always done it with the issue id populated for all issues, even though I really don't need it on the sub-tasks. So my files would look like

  • Issue ID, Parent ID, Issue Type
  • 1,,Task
  • 2,1,Sub-task
  • 3,,Task
  • 4,1,Sub-task

So two issues, one with two sub-tasks.

I once had a problem with the order as well - for some reason, I'd put a sub-task above the issue it was part of, and that failed to import, presumably because Jira was reading one line at a time, but that was in a very old version of Jira and I don't think it goes line by line any more, I think it reads the whole file and works out which issues need creating before their sub-tasks.

Hi, thanks for the response, I updated my file and loaded again but still get the same error.

Parent Issue cannot be null.

That suggests you have a line that names a sub-task issue type, but has no parent ID filled.

One thing to try is filling in every line with a parent id - for the issue level issues, use their own id as the parent (jira should ignore the field for issue level issues)

Re-using my example with that tweak, you would import:

  • Issue ID, Parent ID, Issue Type
  • 1,1,Task
  • 2,1,Sub-task
  • 3,3,Task
  • 4,1,Sub-task

I still get a fatal error, and these instructions do not tie in with the steps provided in the standard user instructions provided by Atlassian for importing from CSV. 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
TAGS

Atlassian Community Events