Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Error message "Problem accessing the file" after upload app on UPM Edited

Hi,

I use Jira-Cloud and tried to upload app on May 13, 2021 (GMT) using UPM that is required to input the URLs for the app (https://subdomain.mydomain.co.th:61111/twpconnector). The error message was shown below.

The last installation with this URLs worked properly for 3 years ago but I uninstalled this app and tried to upload the new one to support the new issue view GUI and face the problem.

messageImage_1620961957827.jpg

I can access via web navigator with the URLs above, but in Jira cloud instance it can't.

 

Can I get the log file to investigate this problem? and How?

Can everyone advise me how to solve this problem?

 

Thanks,

Soraya

2 answers

0 votes

Hi Soraya,

Atlassian Cloud cannot connect to the server (URL) you are entering, probably because the server will be on a corporate network in a VPN. You need to download the file manually.

Pavel

Hi @Pavel Junek 

I can access the URL by using public network properly but on UPM (Manage app > Upload app) it cannot. I cannot find the option upload with file. Can you advise me how to upload app manually?

Thanks

How can I request the log file from Atlassian to find the root cause?

As I can't see anything in the log file on my server and no incoming access through firewall. It seems Atlassian Cloud can't access through the firewall.

But in around 2017 and 2018, I can upload app normally and the SSL config has not been changed for a long time.

0 votes

Er, hang on, there's a huge problem here:

You say "I use Jira-Cloud", but your screenshot is of a Server/DC Jira "manage apps" screen.

Could you confirm whether you are on Cloud or Server?  (Easy check - is the url for your Jira <something>.atlassian.net or something else?)

Yes, I confirm I use Jira cloud and URL is <something>.atlassian.net that there is feature to upload app. I would like to upload my app that run on my server to show something at the right side of the issue view. 

2021-05-14 18_13_18-Window.png

Below is the atlassian-connect.json

{
"modules": {
"jiraIssueGlances": [
{
"icon": {
"width": 24,
"height": 24,
"url": "/twpconnector/images/edit-property-icon.svg"
},
"content": {
"type": "label",
"label": {
"value": "BPS Activity Code"
}
},
"target": {
"type": "web_panel",
"url": "/issuemapping?issueKey={issue.key}&projectKey={project.key}"
},
"name": {
"value": "BPS Activity Code"
},
"key": "bps-activity-code-issue-panel"
}
]
},
"key": "bps-activity-code",
"name": "BPS's Activity Code",
"description": "Set BPS's Activity Code for each issue.",
"vendor": {
"name": "TWP Team @BKKPS",
"url": "https://twp.xxx.co.th"
},
"links": {
"self": "https://subdomain.mydomain.co.th:61111/twpconnector/atlassian-connect.json"
},
"lifecycle": {
"installed": "/installed",
"uninstalled": "/uninstalled",
"enabled": "/enabled",
"disabled": "/disabled"
},
"baseUrl": "https://subdomain.mydomain.co.th:61111/twpconnector",
"authentication": {
"type": "none"
},
"scopes": [
"read"
]
}

Ok, that means that either

  • Your site is unreachable from the outside (this is the usual culprit of this error)
  • Your site is not serving anything up on that url (this usually gives a different error, but not always)
  • Your site is serving up a file that is unreadable (at a glance, your json looks fine, but I'd want to check what it's actually serving up rather than what you've put in the code in the app)

To check all three of these is simple(ish).  Go outside your corporate network (shut down the vpn, or go to a coffee shop and hook up to their wifi) and try 

https://subdomain.mydomain.co.th:61111/twpconnector/atlassian-connect.json

in your browser.  What does that get you?

Yes, I can access to 

https://subdomain.mydomain.co.th:61111/twpconnector/atlassian-connect.json

by using other networks without vpn but upload via UPM not work.

Ok, that suggests that the file being served up is unreadable or contains invalid data that means Cloud can't connect to your server.

I don't think so as I deployed the old application version on my server that had ever been uploaded file on UPM successfully since 2017 until 2019 but recently it cannot. Seem Jira cannot access my firewall.

@Nic Brough _Adaptavist_ , I am the manager for @Soraya Suphasaen . We need your help to provide the log file or error messages to us in order to investigate this issue.

This issue is urgent for our company now.

The previous comment says you've got it down to your firewall, rather than the Cloud side.

The logs from Cloud wouldn't help you even if you could get them, all they would say is that the file served up by your system on the url given earlier is not valid, or that it cannot reach the site (because of your firewall or networking)

Also, I have no access to Cloud, I'm not Support.  This site is a place for people to talk about Atlassian.

Thanks @Nic Brough _Adaptavist_ , we raise this issue to Atlassian Support to follow up this case first.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

335 views 9 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you