Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,618
Community Members
 
Community Events
176
Community Groups

Error 500 when converting subtask to issue

Hi, I'm using Jira Software. Whenever I try converting subtask to an issue, I gen a non-descriptive "500 - internal server error".

I'm the project admin and I should have all the permissions. This happens across multiple different subtasks.

Can anyone suggest what should I check for?

2 answers

0 votes

Looks like this is a permission issue. 
We got it to work after enabling this...

Schedule Issue (Ability to view or edit an issue's due date)

0 votes

Hello @Szymon Sobczak

Welcome to Atlassian Community!

Per your description, I understand you are facing an error when you click in "Move" and try to convert your sub-tasks to issues. Is that correct?

Can you please confirm if the sub-tasks you are facing this problem are in a Next-gen project?

Investigating a little further, I found the following bug reported about your error, reproducible only in a Next-gen project:

Converting a Sub-task of a Next-gen project to issue results in error 500 

If you are using a Next-gen project, please check if the following workaround works for you:

1 - Navigate to your project > Project settings > Issue types > Enable the Story Issue type

2 - Navigate to your sub-task > Convert it to a Story issue type. You will face the same error, however, the sub-task will be properly converted

3 - Change the story to the issue type you want

In case you are not in a next-gen project, please provide us with a screenshot of how you are trying to convert your issues with the generic error you are receiving.

Hi, it's been a while and I've stumbled upon this bug again.

Last time I just manually deleted all the subtasks and created new issues, but this messes up the reports.

I'm not using a next-gen project, this is in a classic one.

This is what I'm doing:

step1.png

Step 2:

(the same error happens for all issue types I can select)step2.png

And the error:step3.png

Like # people like this

Hi everyone,

May be an update on this one ?

We're getting the same error, It also happen trying to convert between Standard issue types.

Like Marcus Polonio likes this
Deleted user Feb 16, 2022

The same error was shown to me too

Hello, we've also discovered this bug. 

Im curious to know if anyone else sees the permission showing as granted via their permission checker? We do, but the group condition fails (the overall status for the permission is granted). 

 

Is it possible the group condition is causing a bug that interferes with this operation?

I too am getting this bug. It's an old project and I'm not an admin on it, but admins seem to be able to do it for me (convert to an issue)!

I am also experiencing this bug. 

I'm also getting this. I'm not admin, maybe that's why, but the error message is not very intuitive in that case.

A user must have the Schedule Issue permission in order to convert from a sub-task to another issue type and vise-versa.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events