Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Could not find driver with class name: com.mysql.jdbc.Driver

I've seen multiple posts with this question but all of the solutions haven't worked for me. I recently installed Jira Software for our Red Hat Enterprise Linux server (v 8.2) and the error "Could not find driver with class name: com.mysql.jdbc.Driver" continues to pop up when when connecting the database. I have placed the .jar file into /opt/atlassian/jira/lib/ but it cannot find the file. I have ran stop-jira.sh and start-jira.sh to restart the service but nothing.

Do I need to install a GUI environment onto our Linux server and access localhost:8080 that way or am I completely missing something?

2 answers

Hi @David Stevens ,

 

If the message still appears, it seems that java can not find the jar.

So maybe you can double check, if it is there and if the user under which jira is running can read it (has the same permissions like the other files).

For this it is not important if you access Jira remote or from the local host. 

The .jar file does have the correct permissions for the user running Jira to read it.

If I recall correct, there where different versions of the driver available and there where multiple files in the driver archive. 

Did you choose the right one and copied the right file from the archive?

We have another server running Jira until we can migrate to the new one and I copied the exact .jar file that server is using for MySQL 5.7.

Hmm, ok, thats weird.

Then I'm getting out of ideas also.

Hi, @Bastian Stehmann _neusta portal services_ ,

So I don't know if you can help me with this part but I think I found the issue. This help article gave me a command to test if Jira is running and it is even after I ran stop-jira.sh. Do you know another way to restart Jira? I believe it never was actually restarted when I previously ran this file so Jira never restarted to find the driver.

I killed the process and ran start-jira.sh to no avail. Maybe that wasn't the issue now.

Ended up re-installing MySQL from the bottom up and it cleared things.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Software

Presenting the "Best of 2020" Jira Software roundup!

Catch up with Atlassian Product Managers in our 2020 Demo Den round-up! From Advanced Roadmaps to Code in Jira to Next-Gen Workflows, check out the videos below to help up-level your work in the new ...

7,175 views 8 28
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you