Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Conversion of Sub-Task to Issue - Not Working

I tried converting a sub-task to issue this morning and there was a failure. Got here because of the way the process to report issues like this is routed.

 

See response page:

 

Screen Shot 2021-06-07 at 1.27.03 PM.png

2 answers

Hello @Chibuzor Obilom,

Thank you for reaching out to Community!

Just for a better understanding of the issue, I would like to know more details about the steps you are following.

Can you please let us if the sub-task you are trying to convert is from a team-managed (next-gen) or company-managed (classic) project?

Is it happening after what step?

Is it happening if you try to convert to any issue type or a specific one?

Are other users able to replicate the issue?

If possible, test on another project.

I tried to replicate it here on my test site and it only happens on a team-managed project when using the option directly from the Search issues page.

Screen Shot 2021-06-07 at 16.39.29.png

Kind regards,
Angélica

Hello @Angélica Luz 

Thanks for your response.

  • Company-managed (classic) project
  • It is happening after the final step of conversion
  • It is happening when I try to convert from sub-task to bug (haven't tried other conversions).
  • I don't feel safe to test on another project or another conversion type as I do not want to flood my team's Jira boards with duplicated information, as is already happening with the current conversion.

Thank you for the details, @Chibuzor Obilom.

I found some errors on the logs related to the conversion and found a similar ticket where the issue was related to the rank system (AKA LexoRank).

Caused by: cloud.atlassian.logmon.laas.api.PrivacySafeException: Privacy-safe boxing of a com.atlassian.jira.bc.subtask.conversion.SubtaskToIssueConversionException

at com.atlassian.jira.bc.subtask.conversion.DefaultSubTaskToIssueConversionService.preStoreUpdates(DefaultSubTaskToIssueConversionService.java:157)

at com.atlassian.jira.bc.subtask.conversion.DefaultIssueConversionService.convertIssueDetails(DefaultIssueConversionService.java:382)

at com.atlassian.jira.bc.subtask.conversion.DefaultIssueConversionService.convertIssue(DefaultIssueConversionService.java:441)

at com.atlassian.jira.web.action.issue.AbstractConvertIssue.doConvert(AbstractConvertIssue.java:313)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

There is one last test to do that may help fix the issue or it may also return some error that will help us identify what is causing it. 

It’s necessary to be a Jira administrator to run the steps below: 

Go to Cog icon > System > LexoRank Management.

On this page, there is an option to Balance all fields and the Integrity checks that will show PASSED or FAILED. If it fails, it will show errors that will help us.

Screen Shot 2021-06-09 at 13.56.28.png

If everything goes fine, then please, test converting an issue again. If still doesn’t work, then it will be necessary to create a ticket so we can access the site to replicate the issue. 

Kind regards,
Angélica

Hi @Chibuzor Obilom , welcome to the Community!

Does this error occur every time you try to move a sub-task to an issue? I would recommend trying this again - there may have been a temporary technical issue with Atlassian's servers.

If the problem has occurred several times and you are unable to move the issue from a sub-task to a non-sub-task, I would recommend raising a support ticket with Atlassian here

Thanks @Callum Carlile _Automation Consultants_ for your response.

This support ticket link brought me to the Community. I could not submit a ticket, because the Explore Community and View Documentation options were the options displayed after I provided my URL.

Screen Shot 2021-06-07 at 6.33.29 PM.png

@Chibuzor Obilom Based on your screenshot, it looks like you're on the Free plan of Jira, and therefore cannot raise a support ticket through my above link. I have raised your issue with someone in the Atlassian team, so hopefully someone will be in touch with you soon!

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Asked in Jira Service Management

JSM June ask me anything (AMA)

Hello Community members! We’re wrapping up the end of JSM June with an Ask Me Anything (AMA) with the Jira Service Management product team. This is your chance to ask all your ITSM questions to o...

268 views 13 14
View question

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you