It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Configure dashboard disappeared

Hi! After clicking "configure" on the upper right side of my Kanban board I'm getting a blank page instead of the actual Configure dashboard therefore I'm not able to make any changes to my Kanban board. Does anyone know why this is happening? 

Attaching screenshot of the blank page to ilustrate.Screen Shot 2019-01-14 at 3.02.20 PM.png

Thanks!

1 answer

0 votes
Jack Brickey Community Leader Jan 14, 2019

@Carol ACF, welcome to the Community. Is this repeatable? Have you tried a different browser? 

Thanks @Jack Brickey! Yes, unfortunately it's a persistent issue - happening for almost a month on all browsers I tried (Chrome, Safari and Frirefox) 

Jack Brickey Community Leader Jan 14, 2019

it appears you are on Server. are you the admin? if not have you discussed w/ them? I wonder if some plugin has been added that is causing this. Are others seeing the same thing, again check w/ admin. Is this happening on all kanban boards?

sorry, don't have an answer for you at this point just a lot of questions. :-(

Hi @Jack Brickeyand thanks again. I am one of the admins and also the project lead :/ no other boards present the same behavior :( the Jira general admin is saying I might need to delete the board and create a whole new one but I really don't want to go through this...

Jack Brickey Community Leader Jan 15, 2019

there is something weird w/ that board for sure. recreating will be relatively easy and I think that is the only option. One suspicion I have is that the filter used to create the board has been deleted or made private. did you create the kanban board or someone else? if someone else can you check w/ them and see if they can view/config? if so check the share settings?

the person who created the board also can't view/config. I checked the filter used on the board and made it public (it was restricted to the team only before) but still getting the same problem :/ 

Jack Brickey Community Leader Jan 15, 2019

curious, how did you determine the filter used for the project. generally i would do that by going to the configure board settings but you can't get there. Assume the owner just knew it? For a quick test just create a new board w/ that same filter. shouldn't take more than a couple minutes to recreate/replace, right?

exactly, the person who created the board for me gave me the filter previously and it's saved on my list of favorite filters so I know which one it is. I'm not allowed to create board as per their permissions here but I shared your suggestion with the Jira admin, let's see! Thank you again! :) 

Hi @Jack Brickey we seem to have found what is causing the configure dashboard to go away! It's the label I created for my team and am using to consolidate our stories on our Team Board. I use labels in my board query (we are a cross functional Kanban team using a ScrumBan type of board) because I need to display on my board stories from different teams, we operate in a very cross functional way and this is extremely important to track the work of our developers across the organization. I've always used labels to do this but never had any issues till about a month ago, would you know if this feature stopped being supported? Thank you!

Jack Brickey Community Leader Jan 16, 2019

NMI, I don't understand how a label would cause this issue. Can you explain further so it might make sense to me? What is the label exactly and how does your board interact w/ that label. FWIW, i'm not a huge fan of labels. Don't get me wrong I use them but am careful w/ how I use them. In the end you might want to consider using Components and making it required at Create issue screen via Validation. But I'm jumping to a solution here before I understand the cause.

Hi! Sure! So, the label is used just to tag stories from the cross functional team that are being tracked on different boards.

The main team is Kanban and its developers also perform tasks that are tracked in stories from other teams - Scrum teams - to have visibility of this type of work I created a label called TeamD and have all stories that are not originally from TeamD but are being developed by members of TeamD tagged with this label. On top of that I went on my Kanban board filter query and included label = TeamD so my board pulls all stories tagged with this label plus TD stories (stories originally created on the main Kanban team board). Make sense?

Jack Brickey Community Leader Jan 16, 2019

so far yes. but that in and of itself does not explain why you get blank screen. So my followup questions are:

  1. how do you know the label is the cause? what is your theory on what the label is doing and have you proven this and or fixed it? if so how?
  2. can you share a screenshot or simply paste your filter here?

i can assure you that labels are still supported so either there is something wrong in your configuration, or misplaced expectations or even possibly a bug. I would like to help you get to the bottom of the issue and resolve or be convinced it is a bug which I am not at this point.

Thank you again!!! :) so here are my answers:

1 - We created a whole new board for the same project but with a very generic query here's the initial query: project = TD ORDER BY Rank ASC while this was the query we could access the configure dashboard with no problem but when we added label=TeamD to the query we lost access to the configure dashboard - that's why we think this was the cause;

2- Sorry, I wasn't the one actually doing these changes so I don't have the exact format of the second query - the one with the label. I can ask the Jira admin to help me out once again though gimme a bit more time. 

Jack Brickey Community Leader Jan 16, 2019

this is quite bizarre and I'm intrigued to say the least. I can't imagine why the label would do this and TBH still thinking there is more to it. More specifically, my doubt lies in the following understanding on my part based upon your input:

board filter: project = TD ORDER BY Rank ASC works fine and can successfully click Configure

board filter: project = TD AND Label = "TeamD" ORDER BY Rank ASC results in inability to select Configure

BTW, were you using OR or AND as the logic operator. OR would be used if the issues spans other projects, AND if all in the TD project.

Here! I got the query that isn't working: labels = TeamD OR project = TD AND status != Done OR project = TD AND status = Done AND resolutiondate >= -40d ORDER BY Rank ASC -- to your point, we used OR because the issues spans other projects

hi @Jack Brickey just wanted to check in if you had a chance to review above filter query :) thanks!

Jack Brickey Community Leader Jan 17, 2019

filter looks ok. i'm now wondering if we are dealing w/ a permission issue associated with one of the projects that uses that label. Some things to try to prove/disprove:

  1. Do you know all the projects that use this label? Can you access each and every project?
  2. If you go to search for issues and enter the JQL of "labels = TeamD" what do you see? While here save that filter.
  3. Can you create a completely new board using the above filter? If so what happens when you try to access the board?

Hi @Jack Brickey here's how it went:

1 - Yes, I can access all projects with this label;

2 - A list of 25 issues across teams tagged with the label;

3 - I created the board and have the same problem, the board works but I can't access "configure"

Jack Brickey Community Leader Jan 18, 2019

Carol, can you try another test please? Try “labels in (TeamD)” 

Just confirming, your suggestion is for me to try to create a new board for the project with the following filter query: labels in (TeamD) OR project = TD AND status != Done OR project = TD AND status = Done AND resolutiondate >= -40d ORDER BY Rank ASC . --- Is that correct?

hey @Jack Brickey I just tried the query above and have the exact same problem, configure board is unaccessible. 

Jack Brickey Community Leader Jan 22, 2019

ok so this is really strange. I would definitely recommend opening a ticket w/ Atlassian Support.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published Feb 26, 2019 in Jira Software

How to prevent the propagation of unused project schemes, workflows & screens in Jira software

Atlassian ranks project attributes as the third most important factor impacting performance in the category of data. It’s not surprising, since project attributes are precisely the rules used to ma...

1,091 views 1 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you