Changing the start date or release date of a version does not work

Editing the start date or release date of a version does not work. The date goes to another date instead of the date I tried to set. I tried setting the date from the Version page using the Edit command and also on the Version view of the issues list using the Pencil command.

I am only trying to change the dates from 7/6/2017 and 7/17/2017 to 7/7/2017 and 7/18/207. Basically, just shifting the dates by 1 day.

I also tried deleting the dates and adding them back in, but they still don't want to accept the dates I entered.

4 answers

1 vote
Ann Worley Atlassian Team Jul 24, 2017

It sounds like people are running into this issue with being in a different time zone from the server:

Releasing a version shows the Release Date one day behind the date originally set

 

I am having the exact same issue in JIRA Service Desk (Server). It moves the date back by one day whenever I set the Start Date or Release Date for a version. 

Can anyone look at this?

Just for clarity, this was happening on our Server instance in 3.4.0, but now we're on 3.8.1 and the same thing happens. We're in the same timezone as our host server, and even if not, that might explain a 1 hour difference, not a 1 day difference.

Hi @Gregory Cline,

From looking over this, it just feels like this is being caused by the documented bug that Ann mentioned in

Releasing a version shows the Release Date one day behind the date originally set

What I believe is happening is that Jira is actually displaying a date such as 7/17/2017, but on the backend, it's actually storing this date/time in a format such as MM/DD/YYYY mm:hh in the database.  As such, Jira is likely choose a time such as a midnight so that the time is stored to the server as 7/17/2017 00:00.   If your profile is even one timezone behind the application/server then Jira could be adjusting the time to cause your display to be 7/16/2017 23:00 to your timezone.  It's the same time, just a different reference point based on a difference of timezone between the Jira application itself, and the user profile viewing that release date.    So this can explain why the date appears exactly one day behind what you actually input. 

By default, Jira is using the timezone of the operating system is it running on.  However this can be changed to an explicit timezone that is different than the OS timezone as mentioned in Setting the timezone for the Java environment

So if your Jira startup options have this parameter defined, then Jira itself is using a different time zone than the server it is running on.

It would probably also help to compare that against the timezone set in your user profile. 

I am experiencing this issue as well.  Here's some more information:

  • When setting a versions release date from the project admin view of releases everything works correctly.
    • Go look at a scrum board's backlog view's version tab.  You'll notice that the release date is 1 day before what was set in the project admin manage versions page
  • When setting a version release date from the Scrum board's backlog view's version tab, it sets, but when you reload the page it will set it back by 1 day
    • If you go look at the project admin's management versions screen, the date is still set to what you originally set it to
  • In both cases, Portfolio also pulls the date-1 date

I don't know how to fix this either, seems like a jira bug.

 

0 votes
Jack Brickey Community Champion Jul 24, 2017

Server or Cloud. Seems to work ok in cloud.

Jack Brickey Community Champion Jul 24, 2017

working fine for me on my instance. could be a different version.  If it persists I suggest reaching out to Atlassian Support.

My problem is on server v7.1.7

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Apr 22, 2018 in Jira Software

How-to setup a secured Jira Software 7.9.0 on Ubuntu 16.04.4 in less than 30 minutes

...PermissionsStartOnly=true User=www-data Group=www-data ExecStart=/opt/jira/bin/startup.sh ExecStop=/opt/jira/bin/shutdown.sh TimeoutStartSec=120 TimeoutStopSec=600 PrivateTmp=true [Install] WantedBy...

2,120 views 14 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you