Cannot use API-token with cURL

Carsten Stepan March 15, 2024

I tried everything from Basic auth for REST APIs ( to get my request working:


I created an API-token on the application. Then I crated a string  in the form "myuser:mytoken" and encoded it using base64. Finally I used that string as authorization-header within cURL:


curl -H "Authorization: Basic <base64string>"


However it keeps returning an empty array, wile it should get me my JIRA-projects.


I also tried to provide the API-token as bearer-token as described here: Using Personal Access Tokens | Atlassian Support | Atlassian Documentation


curl -H "Authorization: Bearer <base64string>"


but that gave me this:


{"error": "Failed to parse Connect Session Auth Token"}

1 answer

1 accepted

1 vote
Answer accepted
Carsten Stepan March 15, 2024

Okay, now it works... created completely new token. Seems like the previous one was broken ;(

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events