Can't enable Greenhopper in Jira 4.4.3

I'm testing out an upgrade of JIRA and Greenhopper, so JIRA v 4.4.3 and GreenHopper 5.8.2.

JIRA shows the Greenhopper plugin as present, but it's not enabled. When I try to enable it, I get messages like

2011-11-10 12:25:12,605 http-8443-1 ERROR PhilipCole 744x36x1 1ouaqh4 10.129.250.10 /rest/plugins/1.0/com.pyxis.greenhopper.jira-key [jira.issue.managers.DefaultCustomFieldManager] Could not load custom field type plugin with key 'com.pyxis.greenhopper.jira:greenhopper-ranking'. Is the plugin present and enabled?

in the logs.

Any ideas?

8 answers

1 accepted

Problem was that I had installed the wrong version of JIRA and I hadn't noticed. Sorted out the versions, and all was good :)

Hi Phil,

Please restart JIRA and then perform a reindex. If that does not work then it is time to get the support engineers to take a closer look, please raise a support request if the restart and reindex is not successful.

Thanks,
Nick

Thanks Nick.

I've restarted and reindexed, but it's still not starting. I have an open support ticket - just hope that we can work out what the problem is.

Phil

Thanks for the suggestion Nick.

I've restarted and reindexed, but it's still notworking :( I do have an open support ticket, so let's see what comes through that.

Phil

0 vote
Dieter Community Champion Nov 10, 2011

Hi Phil,

Are you sure, the Greenhoppr Plugin is enabled?. I get this kind of error messages when the plugin is disabled

Regards,

Dieter

Phil,

What database are you using? Oracle?

I had the same issue when I upgraded from Jira 4.3.4 to 4.4.3 and GreenHopper 5.8.x. I was told it was a known bug. I was having an issue with the upgrade due to the GH plugin after the JIRA upgrade.

So I upgraded to Jira 5.0 and GreenHopper 5.9. Turns out that GH and Oracle 11g don't mix.

I am going to try a fix recommended by Atlassian support, but more than likely your backend DB has not created the tables correctly. Make sure your db user has permission to add tables, sequences, and triggers. Stop Jira and the DB...back them up. Drop the AO_* tables, sequences, and triggers, and then restart Jira, it should then be able to import/upgrade GH correctly. At least that is what I am going to try. If you do this and it doesn't work...let Atlassian support know. You mileage may vary.

I know my DB is messed up, so I have some unhappy users because their GH isn't working.

I should really have come back to this a while ago... My problem turned out to be that I wasn't using quite the versions I thought I was. I had JIRA 4.4 and JIRA 4.4.3 both downloaded and had picked up the wrong one. D'oh. Switched to the right version, and things got better and started working.

Database: MySQL 5.1

Phil

Hi Jirafan, It sounds like we are running into the exact same issue you. I upgraded JIRA to 5.0.2 and GH to 5.9.4 and now GH is not functional. We are also using Oracle 11g database backend. I have already created a support ticket with Atlassian but wanted to know the details of your suggested solution and if it worked out for you?

Thanks,

Thomas

Thomas,

The procedure I followed worked. Ensure your db user has the correct permissions, drop the AO_* tables, and restart. So long as your last export is good, you shouldn't see a problem.

Thanks Jirafan. I was able to get GH working again. I didn't have to delete any AO_* tables. When I checked before adding the additional perms, I only saw 2 AO_* tables in the db so I left it there, grant the perms and restarted JIRA. I also didn't find any triggers or sequences starting with AO_* as well. Everything seems to be working, hopefully there won't be ny long term issues.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Sarah Schuster
Posted Mar 28, 2018 in Jira Software

Can a company’s culture make or break agile adoption?

Can a new-to-agile team survive and thrive in a non-agile culture? If so, what advice would you give to those trying to be agile in a non-agile culture? What's the key(s) to success? Share your thoug...

12,057 views 15 13
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you