Can not build GreenHopper from source?

Hi All, I have downloaded GreenHopper source version 5.7 and tried to build it, but there are two problems in my pom file.

1. in jira-greenhopper-parent-pom file the greenhopper-integration-test module can not be resolved by my IntelliJ IDEA in

<modules>

<module>greenhopper</module>

<module>greenhopper-integration-test</module>

</modules>

2. in jira-greenhopper-plugin pom file there are multiple value marked as unresolved within maven-antrun-plugin, example value="${touch.time}", value="${changeSet}", input="${changeSetDate}", defaultValue="${changeSetDate}"

${changeSetDateFixed}, value="${changeSetDateFixed}".

The plugin tag starting with <plugin>

<groupId>org.apache.maven.plugins</groupId>

<artifactId>maven-antrun-plugin</artifactId>

.

.

.

Please help, thanks.

4 answers

1 accepted

0 votes
Accepted answer

Hi Alex,

As the build number is required please add '-DbuildNumber=null'. Are you trying to build using the Atlassian Plugin SDK? If not, please do so.

What is the problem you are trying to solve? Perhaps there is an easier way.

Thanks Alex,

Nicholas Muldoon

Thanks for the reply. I am using IntelliJ IDEA 10.0 to build the GreenHopper from source code. It has a maven tool integrated so I just click compile and then package to get the GH jar file. where to add the -DbuildNumber=null in IDEA?

And I also tried to build it using sdk, I open a cmd window and go to its root directory where the new downloaded file located, and type atlas-cli, the first thing is it complains could not find the model file "greenhopper-integration-test", and after I comment out its line, it says build failure Couldn't detect an AMPS product to dispatch to... it seems have different error messages from when I using IntelliJ IDEA.

All I want to do now is to add some conditions to the drop down list of cog, hide some options based on some conditions, for example hide "log work" if the issue type is bug, hide create subtask when issue type is Epic, etc. Is there a eaiser way to achieve that so i don't need to rebuild GreenHopper from source? Thanks.


I use sdk and type in atlas-compile but it complains buildnumber error, then I tried atlas-compile -DbuildNumber=null but it seems not to be the right command. where should I add -DbuildNumber=null to? Thanks.

and even if I comment out all the error caused line like " <!--goal>hgchangeset</goal-->", the packaging process still has error in IntelliJ IDEA,

Error occurred during initialization of VM

Could not reserve enough space for object heap

Could not create the Java virtual machine.

while I have already increased its vm memory size to

-Xms256m

-Xmx768m

-XX:MaxPermSize=512m

-XX:ReservedCodeCacheSize=128m

-ea

Please help. Thanks.

After I commented out those tags, still the compile error is

[INFO] [buildnumber:hgchangeset {execution: default}]

[ERROR] is not recognized as an internal or external command,[INFO]

You can do an 'atlas-run --help' for full options. To run, and test, the changes you made locally use:

'atlas-run --product jira -DbuildNumber=null'

To build you'll want to use 'atlas-package'.

Thanks Alex,

Nicholas

So I today tried to compile two versions of GH (5.6.8 and 5.7) from their source distributions.

I've used Atlassian SDK 3.5.2 and clean Maven repo and settings (I removed my ~/.m2/settings.xml and ~/.m2/repostitory to make sure that nothing in my local mvn configuration affects the results.

For both versions the experience was exactly the same:

- cd <root dir of your unpacked src distro/greenhopper (do not compile in top level where parent pom is present)

- comment out buildnumber-maven-plugin (entire <plugin> section) in pom.xml

- <atlassian-plugin-sdk-3.5.2 inst dir>/bin/atlas-mvn package

After downloading 3/4 of Internet (gazillions of poms - like maven scm baazar integration - Maven I love you...) this stuff was successfuly built and all unit tests passed successfuly

I used Ubuntu 10.04 32-bit with Java version "1.6.0_26"

WRT IntelliJ integration - I would remove greenhopper-integration-tests module from the parent pom. Various errors reported by IntelliJ should be rather harmless (once you compile from command line). And you can always resort to command line (I know, it sucks when you want to run a single test or something).

Let me know how it goes.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Mar 28, 2018 in Jira Software

Can a company’s culture make or break agile adoption?

Can a new-to-agile team survive and thrive in a non-agile culture? If so, what advice would you give to those trying to be agile in a non-agile culture? What's the key(s) to success? Share your thoug...

17,661 views 18 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you