Agile Classic Project Progress Gadget Not Displaying "To Do" or "Done"

Right now my gadget only tracks "In Progress" even though I have two issues that are marked as "To Do". How can I make sure my gadget tracks issues properly? In the screenshot below, the issue INT-1 has a status of "To Do" but the gadget only shows 2 "In Progress" issues.

Screen Shot 2015-04-23 at 3.51.54 PM.png

1 answer

0 votes

Hi, Jared.

I honestly don't know who that gadget works, but it seems to me that it's using status categories, not the status themselves. That is, it seems, for example, that it is aggregating all status of 'In Progress' category in the yellow color (which is indeed its color).

You should check that by add issues to statuses of those categories and seeing if they affect the category.

I hope it was helpful.

Kind regards,
Jaime Kirch da Silveira
Atlassian Cloud Support

Hi Jaime, Thanks for your reply! I'm a bit new to JIRA so I have a question about your answer. My "status categories" are 'To Do', 'In Progress', and 'Done', right? And the statuses are the same, but are determined by where the issue is in the workflow? If that's right then all of my issues are in Sprint 1, marked with a status of To Do. I've started and stopped progress on the issues but nothing has changed. The status seems to be right, but it's not reflected in the gadget. Thanks for your help.

Hi, Jared. JIRA has 2 concepts: statuses and statuses categories. The status categories are only 3: To Do, In Progress and Done. They cannot be changed, removed or new added. The status are customizable and you can add and remove. Each status has a category, one of the three. The status in each workflow are mapped to workflow steps and each step is a position in the workflow. In other words, the status indirectly tells which step you are in the workflow. That is, is pretty similar to what you said. If you status to status categories are correctly mapped, this should work and the gadget should change. Since it does not, I'm not sure what is causing. Maybe is because this is Classic Agile gadget and classic agile is no longer supported in Cloud. If you need some further investigation, you can open a support request at support.atlassian.com in the Cloud project. Kind regards, Jaime Kirch da Silveira Atlassian Cloud Support

Thanks Jaime. I checked the statuses and their status categories and everything matched up correctly, so it may be an issue with classic agile not being supported. Thanks for your help!

No problem, Jared.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Mar 28, 2018 in Jira Software

Can a company’s culture make or break agile adoption?

Can a new-to-agile team survive and thrive in a non-agile culture? If so, what advice would you give to those trying to be agile in a non-agile culture? What's the key(s) to success? Share your thoug...

17,657 views 18 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you