Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,526
Community Members
 
Community Events
176
Community Groups

Jira Knowledge Base setup with Confluence issue

Hi,

I have tried to link my Jira SM Knowledge Base to use Confluence base on this instruction https://support.atlassian.com/jira-service-management-cloud/docs/manage-knowledge-base-permissions-from-your-service-project/, and it worked.

However, when I tried to change "Who can view" setting to "All logged-in users" it gave me an error like below. I remember when I tried it once for testing purpose and it worked but when I changed it back it didn't. Did I miss anything?

jira-conf-error.jpg

Thanks.

Regards,

Hendra

1 answer

0 votes
Mikael Sandberg Community Leader Dec 20, 2022

Hi @Hendra Liu

Welcome to Atlassian Community!

The Anyone option has restrictions to it, you need to be on Confluence Standard plan or higher, and you have to enable anonymous access in Confluence. Have a look at this KB for more information regarding viewing permissions for knowledge base.

Hi Mikael,

Thanks for your reply, as mentioned in my question, I only want to change it to "All logged-in users" and the KB you mentioned is the same as I mentioned as well. Thanks.

Mikael Sandberg Community Leader Dec 20, 2022

Okay, so you may want to try and change the setting in an incognito window to see if it works there. You could also try clearing your browser cache and history to see if that works.

Hi Mikael,

I just tried your suggestions and didn't work as well. I tried:

- Clearing browser cache & cookies

- Change the setting in incognito window

- Tried on other browser Edge

Trudy Claspill Community Leader Dec 20, 2022

@Mikael Sandberg 

I've been corresponding with another user in another post who has the same problem. They also don't want to enable Anonymous access for the Confluence space as they want only customers logged in to the Portal to be able to access the Confluence information.

I've not been able to figure out the issue.

https://community.atlassian.com/t5/Jira-Service-Management/Customer-Access-to-Knowledge-Base-created-in-Confluence-through/qaq-p/2217996

Like Mikael Sandberg likes this

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events