Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,145
Community Members
 
Community Events
165
Community Groups

JSM Report Series, adding Filter By is not working

Edited

When i go to my JSM, click on Reports, Create a new Report, then add a Series, it opens up the "Edit a Series" popup.

Within the popup, i have the option of adding JQL (advanced / Basic). This worked perfectly up to two days ago. For some reason, it does show the field i want to add to the JQL, but it wont allow me to choose / add it.

This happens with all fields. What is wrong?

Screenshot (2).pngimage (1).png

 

3 answers

1 accepted

0 votes
Answer accepted

Turns out there is a bug in Jira. they seemed to have fixed it over the weekend. so indeed the above was an issue.

0 votes

Could you describe what is actually happening here? 

In your first screenshot, you are starting to enter a field name as part of a JQL query, so I assume you're going for something like "issueype in (bug, feature)", but you don't tell us what "it won't let me add it" is.

 In your second screenshot, the message is clear - the field you are trying to put into the query is not used in the current project, so your query on it will always do nothing.

In the third, it looks like your saved query was just "all issues"

@Nic Brough _Adaptavist_ exactly, i am starting to type "issuety.." and it is showing the result, but wont allow me to click/select it. Even if I move to "Switch to Basic", it shows the field, but its greyed out. This happens with ALL fields. And once again, it worked perfectly up until this morning.

Regarding the third one, i clicked on Edit Series and this window pop-uped up with an empty JQL field, yet i know its not empty, because it worked before. Again, no sure what is going on.

 

All those fields are used in this project. When i do an Advanced Search (under Filters in Jira), it works perfectly and brings back the correct results. It has to do with something in Series/Reports.

 

thanks

I tried to Edit a Series i created in the past. When i click on Edit, it shows the JQL as empty field. Could something be wrong in Jira?Screenshot (3).png

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

Coming Soon: Insight Changing to Assets

The 2020 acquisition of Mindville added powerful asset and configuration management capabilities to Jira Service Management in the form of Insight. Following the completion of that integration, custo...

250 views 1 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you