Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

How to add custom field to plan screen

I created my own plan and for filter I like to add some custom field. Since I am Admin, I can see the Custom fields that I need for Plan, but I just don't know how to add that Custom field to my plan custom field. Any suggestion?

2 answers

1 accepted

2 votes
Answer accepted

@Sutapa Basu -

When you click on "Adding the custom fields" option from your plan's configure > custom fields, you should see a similar screen like this below.  Are you saying that you don't see the popup at all?  Maybe a screenshot for us to assist you further?


Take a look at the following page for your reference -

Best, Joseph Chung Yin

Jira/JSM Functional Lead, Global Infrastructure Applications Team

Viasat Inc.

Thanks for the feedback. Yes I see the pop-up and custom field, from the above screen you mention, but I don't see the custom field i want under the that pop-up. How can I add my custom field under that pop-up?



@Sutapa Basu 

Have you tried to search for your field?  Please note - Please enter the exact field name when searching.  Also, please ensure that the "Hide unsupported fields" checkbox is not checked.  It can be that your custom field's data type is not supported in Plan.


Only the following custom field types are supported in Advanced Roadmaps:

  • teams

  • checkbox

  • date picker

  • user picker (single user)

  • number

  • radio button

  • single-choice select

  • multiple-choice select

  • single-line text

  • URL (read-only)

Here is another link that may help you -

Best, Joseph

Thanks Joseph for the feedback. Yes I entered the exact field name when searching and Hide unsupported field is uncheck. But I still don't see the use the custom field that I am looking for. This of custom field types you mention above, how do I know the field I am looking for is part of that custom field types?



@Sutapa Basu -

Assuming you have the system admin right, then you can access the clog wheel "Settings" >> Issues


WIthin the Issues UI, click on Custom fields, you will then be able to see the data type associated with your fields


Lastly, can you check to see if your Jira/JSM projects are Team Managed type or Company Managed type?  If it is Team Managed type, then this explains why you don't see the custom fields for your plan.  If a project is Team Managed type, everything is local and can only be access via the project itself.

Best, Joseph

0 votes
Fabian Lim Community Leader Apr 18, 2022

Hi @Sutapa Basu

Welcome to the community!

are you referring to a roadmap plan? Any screens hots that you can share to give more context of your issue?


Yes it is roadmap plan. I created my own plan and then under Filter I see there is Manage Custom fields>That takes me to Custom fields page>then I click Manage your custom fields> it took me to Custom fields page> I select the custom field (ex: Story Point)> I click ... for that specific custom field and select associate to a screen and this is where I am lost, I am not sure how this specific custom field can be add to my road map plan. Any help will appreciated.


Yes I tried the above link,  but it didn't help


To add a custom field to a plan:

In your plan, click more () next to the plan name > Configure > Custom fields.
If your plan doesn't have any custom fields yet, click Add custom field.
In the Custom fields page, click + Add custom field. (I am not seeing the Story Point custom field in this list, so I click Add Custom Field and it took me to custom field page).

I am also experiencing this exact issue. "Story Points" custom field is not displaying in the "Add Custom Fields" drop down for the "Advanced Roadmap" plan.

All other fields display, but that one doesn't, even when unsupported checkbox is clicked.

Suggest an answer

Log in or Sign up to answer

Atlassian Community Events