It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Error after Upgrade Jira 7.13 =>8.9.1 Edited

I have upgraded test environment from 7.13 to 8.9.1 and service desk 4.9.1. I have also upgraded all plugins include Insight.

After upgrades it gives Something went wrong.Contact administrator.

There are WARN in atlassian-jira.log file

2020-06-21 17:06:29,848+0400 SdSerialisedOffThreadProcessor:thread-1 WARN      [c.a.j.cache.request.RequestCacheImpl] Incorrect usage of JIRA API. You can only create/use: RequestCacheImpl inside a context (request or Jira-Thread-Local). Check: JiraThreadLocalUtil for details.
2020-06-21 17:06:29,848+0400 SdSerialisedOffThreadProcessor:thread-1 WARN      [c.a.j.cache.request.RequestCacheImpl] From Jira 9.0 version creation/usage of RequestCacheImpl will throw the IllegalStateException.

I have tried to use this in log4j.properties and it didn't help me.

log4j.logger.com.atlassian.jira.cache.request.RequestCacheImpl = ERROR, filelog
log4j.additivity.com.atlassian.jira.cache.request.RequestCacheImpl = false

https://jira.atlassian.com/browse/JSDSERVER-6897?_ga=2.111594759.224273647.1593551794-1615353982.1582310973

 

I have also tried restore to restore Insight to the previous version of plugin that was installed. I have cleaned all plugins caches and this error on the web page disappeared. 

When I update Insight to the newest one it is appear again.

image-2020-06-21-17-22-09-636.png

1 answer

I have the same issue after upgrading our QA from 8.7.1 to 8.9.1.

 

Can concur, when removing Insight the error goes away from within Jira, but the errors in the log to do not. The moment Insight is reinstalled the error returns.

 

But I would suspect it's a bug in the way Insight is trying to handle things

Hi. Do you have any ideas to solve that?

Not at the moment. Will update if I figure it out.

We have the same issue on our testserver, I have created a ticket to Mindville. 

So there was a preparation guide that needed to be followed. The steps I received from mindville are as follows:


The Steps to take now, as you have upgraded already are as follows (and here is the MSSQL Database example):

Start by uninstalling Insight (no Data loss is expected)
When uninstalled, query the database:

ALTER TABLE AO_8542F1_IFJ_OBJ_ATTR_VAL DROP CONSTRAINT fk_ao_8542f1_ifj_obj_attr_val_object_attribute_id;

Then, run the following SQL query:

UPDATE propertystring SET propertyvalue = '75' WHERE id = ( SELECT id FROM propertyentry WHERE property_key = 'com.riadalabs.jira.plugins.insight:build');

Install Insight version 8.5.2 (currently recommended) or 8.6.0
After installation, query the database:

ALTER TABLE AO_8542F1_IFJ_OBJ_ATTR_VAL ADD CONSTRAINT fk_ao_8542f1_ifj_obj_attr_val_object_attribute_id
FOREIGN KEY (OBJECT_ATTRIBUTE_ID) REFERENCES AO_8542F1_IFJ_OBJ_ATTR(ID);

Then (for MSSQL ONLY):

UPDATE AO_8542F1_IFJ_ICON SET TYPE_ID = 0 WHERE TYPE_ID IS NULL

It is important to run a clean re-index of Insight when the above steps are done.

Like Hakan_Bahadir likes this

Just followed the steps and all working now.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you