It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Automation error msg: The selected default user is not able to run automation rules

After I setup a german servicedesk I started to setup a copy of this servicedesk as english version. Workflow, automation and SLA´s were copied to the new project.

Unfortunately in the automation section I receive the error msg.: The selected default user is not able to run automation rules.

If I try to select another user, there are no matches found ( not even myself)

Instead I receive the msg:  The selected user has been deleted.

I set up the same set of users as in the prior project.  I have the rights as Jira Administrator in both projects and I´m signed in.

How can this system tell me that I am deleted when I´m successfully logged in?

Didn´t find anything about this specific issue in the community.

Even if I try to setup new rules I receive the same error.


Can anybody help here? This issue is a blocker to me!

5 answers

It's just an interface bug. If you click on the dropdown to select a user, none will be displayed (in my case the error was caused because we removed the associated user from Jira). If you put the cursor on the beginning of the user name and start typing your user name, it will display a list of matching users to select. This solved the problem to me.

Thank you, Leandro! This fixed my problem :)

Like # people like this

This solved my issue, Thank you

Thank you. This worked for me too!

Thanks. The issue continues but I find myself with your trick!

I'm facing the exact same issue, were you able to find a workaround or what the problem was?

Hi Stefan,

The "The selected user has been deleted" message. is really weird, but in automation section it says:

Unless otherwise specified, the rules for this service desk run as the following user. This user should:

  • Be able to view issues in this service desk
  • Have the permission to perform the actions the rule carries out

This is usually the user who has the Jira Service Desk Agent.

Best Regards

MoroSystems Support

I'm getting the exact same issue, and unfortunately, I can't even figure out how to report a bug to Atlassian other than coming here and asking for a solution.

Anyone get an answer to this? In my case, the user was an actual human user who left the company.  When I deactivated their account, I started seeing this message.  So I created a non-human user for this purpose and can't select them from the list.


EDIT:  Sorry, didn't mean to make this an answer.




I was able to see my user in the list and select it after typing the entire name, "jirarules".  I had been typing "jira" and getting a long list of other users, including "tfs4jira", so I assumed it was filtering as expected, but apparently not.  My own user appears when I type just "cha", though ¯\_(ツ)_/¯




Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you