how long does it take for links jql to work?

For JQL Search Extension plugin.

Using Jira cloud.

I installed the plugin and tested by using this JQL

linkedBy in (PROD-880)

The linkage existed before I installed the plugin.

I got results showing what issues were showing in the links section for that issue. 

I then went to a different issue and newly linked up about 10 other issues. I tried the exact same query with the new issue. There were no results. 

Do I need to run an index? What's the deal? 

 

3 answers

Hi Jase,

It looks like your instance is still synchronizing on our end. Depending on the size of instance it can take anywhere between 5 minutes to a few hours.

I can see that the addon can't access issues form the PROD project (or any other project I guess). Please change the permissions and we will need to re-run the full sync again. 

Let us know once the permissions are taken care of!

 

 

To follow a review poster said - I'd really need to know how the data is moved around here. You're website says only the account information JSON is stored but it sounds like all our issues are syncing to your server. At the least, let me know, but I'd suggest you put a page on your wiki that covers this. It looks like the sync has worked and I'm seeing the filtered issues now. Before we buy though I'll need to clear the data aspects with our CIO. 

The addon needs to be authorized to access JIRA issues data from your instance. This data is only used while processing on our server but it is never stored in our database. We only store information necessary to authenticate your JIRA instance.

 

So in short the add on reads the data but it never stores it on our side.

And just to make it absolutely clear: we are not storing nor logging any of this data.

Daniel,

We are having issues. It's just not working. I have PROD-1107 with lots of links

image2016-11-20 7:33:34.png

I've waited days for it to sync. It's not working. 

image2016-11-20 7:34:11.png

image2016-11-20 7:34:35.png

We put alot of work into linking assuming this would work - can you please help? 

Hi, what is your JIRA instance address? I will look into your problem asap.

Jase, the add-on still can't write metadata on issues. Please correct the permissions on your JIRA instance by following the tutorial (chapter Add-on permissions) : https://jqlsearchextensions.atlassian.net/wiki/display/SEARCH/JQL+Reference#JQLReference-Add-onpermissions

After the permissions are corrected I need to run re-indexing on our side.

Usually links are indexed within seconds but sometimes it takes minutes. Initial indexing after installation takes anywhere from a few minutes to a few hours depending on the number of JIRA issues.

Let me know how it goes with the permissions!

thank you - the atlassian-addon-project-access was not added to the edit issues ability in the associated scheme. I have fixed that now - can you reindex? 

Ok, I'll reindex, it will probably take at least an hour. I will let you know when it's finished.

The indexing has finished. Please verify the results.

It's working great now. Thanks for your help.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Confluence

Three common content challenges + how to manage them

An efficient enterprise content management system, or ECM, is a must-have for companies that create work online (cough   cough, all companies). If content calendars, marketing plans, and bu...

93 views 0 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you