Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

error: JIRA could not attach the file as there was a missing token. Please try attaching the file again. on Google Chrome

error: JIRA could not attach the file as there was a missing token. Please try attaching the file again. It happens on Google Chrome today.

19 answers

1 accepted

12 votes
Answer accepted

This happens when there's a network error, or timeout.  The easiest way to replicate it is to leave the computer for a while and then try the action - your tokens expire. Sometimes, it can happen when you're trying to upload too large a file as well.

Have you tried it again yet?  If you did, what happened?

"leave the computer for awhile and then try"

OMG, so let's define "awhile".  A minute?  An Hour"? A day?.  Do I leave the computer and go sit in another room or do I have to leave the building?  Or can I just throw a blanket over it so it thinks I left.    Maybe I could leave it at Atlassian headquarter and they could fix it.

Priceless.

Like # people like this

No, that is clearly not what I said.

Please try reading the answer properly and thinking about it in the context of the question that was asked, instead of being silly.

Like # people like this

Hi Nic, I was wondering what you'd advise if a user has experienced the same issue in multiple browsers, using various different files and a number of different tickets? Cache has been cleared, the user has logged in and out of JIRA...nothing basic seems to work.

And she didn't leave her machine for a while either...literally fired up a new browser, logged into JIRA, tried to attach a file...and got the same error.

Like # people like this

Hi Nic , 

you are right that is a timeout err , just refresh the page and perform the operation .

it worked.

Like # people like this

Thanks Nic. That helps

After refreshing the page couple of times it works for me.

Like # people like this

I had two tabs open to JIRA. All I had to do was refresh the given tab and there was no more token error. 

2 votes
AnnWorley Atlassian Team May 10, 2017

Could it be that people have Confluence open in another tab and and it's overwriting the JIRA cookie?

Logging into another Atlassian application logs me out of Confluence

I doubt the case, because I never run Confluence. None of them listed here work. Any resolution from Atlassian?

logout from jira and login again. That's Solution

No, that is not a solution, that is a workaround.

Like Jonathan_Oberländer likes this

..only if it would work! In this case it's an "it also doesn't work around"

1 vote
Deleted user Mar 12, 2019

Any new information on this? I just encountered it while testing JIRA 7.13. In my case, this was while trying to attach a file in the "Create Issue" screen. There's no way that I know of to "refresh" that dialog - so I completed the Create process and attached it later - but my users aren't going to like having a field for attaching documents for submission and seeing that error. It's just a wee bit off-putting.

+1
We've just started getting reports of this issue happening in Chrome on version 7.13.8. No Jira updates or changes to the network stack recently.

A tab refresh seems to allow the user to complete the current operation, but they're reporting that they're seeing the issue multiple times a day and having to refresh each time to get around it.

Interestingly, users are reporting that the issue seems to go away when they use Firefox.

Almost 4 years since the first response in this thread and it still hasn't been fixed. I am currently using Chrome Version 83.0.4103.116 and can't upload a file that is 758KB without the token error. Tried the wait, logout/login/refresh..... What will it take for this to be rectified. 

I read the first answers above, and refreshed the tab after writing a long defect report—and lost the whole thing. 

I despise stupid problems like this, and they seem to be all over atlassian software. 

 

Sorry, just venting. 

This happened to me today on Firefox (50.1.0).  Earlier today, I cleared my entire Firefox history/cache/cookies/etc.  My network is fine and the file is only 392k.

Just happened in Chrome as well...

Happening in Chrome even though "Block third-party cookies..." is disabled.

this is happening when login to JIRA from Confluence space shortcut link.

this is not due large file or session time out, this could be bug.

How is this an acceptable answer? "This could be a bug"?

Someone accepted a useless and wrong answer here, so people stopped paying attention.

Have a look at where Ann and I give useful answers.

For me too "Happening in Chrome even though "Block third-party cookies..." is disabled."

This is happening to me in Chrome.  Did anyone ever find an answer?

I'm encountering the same problem today on Chrome when I try to attach an image or excel file to a bug in jira. I am not running Confluence.

Well, I might as well add my voice that I can't attach a file in Chrome while using Jira 7.2.8 (no Confluence, no one overwriting my cookies, just plain broken)

BTW, works fine in Firefox.

Refresh worked for me here as well.

 

Logout from jira and login again.

Refresh the tab works !

For me, I changed the file format. I was trying to update a png, but when I updated a jpg of the same file it worked fine. 

Suffering this constantly, very disgusting. Any open bug about it? I cannot think about restaring sessions all the time

Refresh the browser page and retry attaching the attachement.

That works!

This can also occur if you are trying to drop an attachment on an issue that has an open comment.  Simply select Add to close the comment and the attachment should work.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Core

How to manage many similar workflows?

I have multiple projects that use variations of the same base workflow. The variations depend on the requirements of the project or issue type. The variations mostly come in the form of new statuses ...

4,248 views 12 5
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you