configure ssl for jira links

Hello

we are having currently troubles of configuring ssl for the jira links.

when importing certificate the server is not responding

 

5 answers

0 votes

Hi there,

Can you let us know which step you're stuck on? I assume you're going over our Running Jira over SSL article.

Please also see if you can find any error messages in the Jira application logs and any other messages you might have seen. It will help us to see which part of the issue you're having a problem with.

Kind regards,

Shannon

hello

after I click on save configuration and a new dbconfig.xml is written

then on reboot the service can't be started

Thank you Chrysovalantis,

In that case we will really need to see your logs.

Please have a look at your Jira application logs that I mentioned earlier, and show us what errors are occurring while you try to reboot Jira.

Thank you!

Kind regards,

Shannon

little bit confused with this

C:\Program Files\Atlassian\JIRA\logs

C:\Program Files\Atlassian\Application Data\JIRA\log

I have two log directories but no application log

 

which folder=

0 votes

Hi Chrysovalantis,

I understand that you are trying to configure SSL for Jira, but after doing so Jira can't be started.   If this is Jira 7.3.x or higher, then I believe I know the problem here.

There is an existing bug in the Jira Configuration Tool that sets the incorrect protocol for the $JIRAINSTALL/conf/server.xml file.

This problem is also documented in the 7.3 upgrade notes.  That page has steps to follow to correct this problem:

To update the required protocol:

  1. Make sure JIRA is stopped.
  2. Navigate to your server.xml page at <JIRA_INSTALL>/conf/server.xml.
  3. Locate your HTTPS connector, which will look something similar to this:

    <Connector port="8443" protocol="org.apache.coyote.http11.Http11Protocol"
                  maxHttpHeaderSize="8192" SSLEnabled="true"
                  maxThreads="150" minSpareThreads="25"
                  enableLookups="false" disableUploadTimeout="true"
                  acceptCount="100" scheme="https" secure="true"
                  clientAuth="false" sslProtocol="TLS" useBodyEncodingForURI="true"
                  keyAlias="jira" keystoreFile="<JIRA_HOME>/jira.jks" keystorePass="changeit" keystoreType="JKS"/>

    and change the protocol so that it looks more like this:

    <Connector port="8443" protocol="org.apache.coyote.http11.Http11NioProtocol"
                  maxHttpHeaderSize="8192" SSLEnabled="true"
                  maxThreads="150" minSpareThreads="25"
                  enableLookups="false" disableUploadTimeout="true"
                  acceptCount="100" scheme="https" secure="true"
                  clientAuth="false" sslProtocol="TLS" useBodyEncodingForURI="true"
                  keyAlias="jira" keystoreFile="<JIRA_HOME>/jira.jks" keystorePass="changeit" keystoreType="JKS"/>
  4. Save your changes.
  5. Start JIRA.

Try these steps.  If Jira still will not start after doing this, then we would like to see what kind of errors exist in the $JIRAINSTALL/logs/catalina.out file from this time.   That should be able to tell us more about this problem.

Regards,
Andy

Hello Andy

it is working now, the only problem I have is that the servicedesk module is available on both 8080 and 8443 ports.

how can I redirect the servicedesk page from 8080 to 8443.

do you have any idea?

 

regards

Chrys

Hi Chrys,

There are a couple of different solutions.  You could completely remove the 8080 connector from the server.xml at which point no one could connect there, or you could make sure that this 8080 connector has a redirect parameter in it such as

<Connector acceptCount="100" bindOnInit="false" connectionTimeout="20000" disableUploadTimeout="true" enableLookups="false" maxHttpHeaderSize="8192" maxThreads="150" minSpareThreads="25" port="8080" protocol="HTTP/1.1" redirectPort="8443" useBodyEncodingForURI="true"/>

Which in turn should redirect requests made at 8080 to 8443.

But this would apply to all requests made to 8080, not just those that pertain to Service Desk

Hello Andrew

thank you for your reply

the redirection entry exists in server.xml

 <Connector acceptCount="100" bindOnInit="false" connectionTimeout="20000" disableUploadTimeout="true" enableLookups="false" maxHttpHeaderSize="8192" maxThreads="150" minSpareThreads="25" port="8080" protocol="HTTP/1.1" redirectPort="8443" useBodyEncodingForURI="true"/>

 

But the servicedesk page is not redirected and is available as both 8080 port and 8443 port,

The jira core page is redirected without problems and is only available on 8443

Do you have any idea?

 

kind regards

Chrys

 

 

Suggest an answer

Log in or Join to answer
Community showcase
Teodora [Botron]
Published Thursday in Marketplace Apps

Jira Inferno: The Nine Circles of Jira Administration Hell

If you spend enough time as a Jira admin - whether you are managing a single, mid-sized instance, a large enterprise one or juggling multiple instances at once - you will eventually find yourself in ...

274 views 0 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot