It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Updated Issue Types not updating display

Deleted user Mar 13, 2017

I've got a Server install of JIRA 7.3.2.  I've been building out some custom issue types before we begin using it in production.  I created several issue types, added them to the scheme for the project, and everything looks fine.  I also renamed the "Bug" issue type to different text because bugs are "bad".  

 

When I go into the create screen, I see all of the issue types that are in the scheme for this project.  However, "Bug" is still "Bug" not my "Change Needed" text.  Also, the icons for the new issue types remain as the default.  Once I've created an issue, Issue type and icon display as expected.  I've done normal browser troubleshooting as I'd expect (cleared cache, cycled the browser, etc) but I'm still stuck.

 

Any ideas/suggestions?

10 answers

1 accepted

30 votes
Answer accepted

I just found (based on above answers that, even easier --- in any/all applicable "Issue type schemes" simply *move* the affected issue type up or down in the list (drag and drop), and *save* - and the text will now be correct. You can now move it back to original position if wanted. Not something you should have to do but it works. 

I just tried your workaround and it is working fine.

Thanks!

Like Antônio_Duarte likes this

Thanks @Glenn Morrow for sharing this valuos info. It has worked like a charm.

This was way better than recreating all my tasks, thanks.

Yep! Glad to help.

Glenn, Well that is the silliest thing I have ever tried, but yippie!!! it worked.  Thank you!!

Yep - silly but works! I have used t several times since myself.

Hey it worked for me too...crazy!!

Like Glenn Morrow likes this
Like Glenn Morrow likes this

Thanks, that worked. But as you mentioned, that is not something you need to do or something you can expect. 

Atlassian should solve this bug, that's really annoying.

This worked for me too. When you get to the Issue Type Scheme for the particular project you'll see that the old name is still there in the scheme. All I was move the issue type, down, hit save. And it actually updated to the current new name. 

 

Thanks for the advice here. 

It worked for me to. I even re-index the project but not working.

This worked for me too. That was just great. Thanks :)

Editing the default issue type scheme (which we don't use) and setting the default issue type to the issue type that was changed, save it and then resetting to back to none finally cleared the cache.  

Why not create a new issue type name "Change Needed" and exclude Bug for Issue type scheme of all project ?

Deleted user Mar 13, 2017

Because we won't be using "Bug" and I'd rather limit extraneous issue types.  It's an option, but that would just give me yet another issue type that's displaying the default icon in the Create Issue dropdown for issue type, which is the other issue I've run into.

Have you tried a reindex?

 

Deleted user Mar 13, 2017

I just did a lock and re-index (joy of it not being live yet, there really aren't many issues and it completes lightening fast)... and no luck.

I ran into the exact same issue  (also on JIRA server version 7.3.2) when updating the name and changing the icons of a few custom issue types.

I tried resaving the updates to the issue types, updating the issue type scheme, and doing a full re-index. Nothing worked.  I even created a new issue type scheme using the updated issue types (thinking maybe the old issue type scheme was hung up is cache) and while it would show the changed issue type name and icons in the issue type drop down menu, as soon as you selected one it would revert back tot he previous version. 

Finally I figured out that if you restart your JIRA instance the updates will be displayed as expected.  However, restarting JIRA every time you make a change to an issue type is not a great solution for a production environment.

Here is a very old bug that describes this behaviour - https://jira.atlassian.com/browse/JRASERVER-23148

But we've only hit it for the first time ever today. Must be something else going on to cause it.

I've experienced the same issue and what solved it for me (we currently use Jira 7.2.4) was to create a copy of the assigned Issue Type Scheme and assigned the newly created copy to the project.

I've just experienced the same, and I've had to edit and save each "Issue type schemes" having the modified issue type declared. Jira Software version 7.2.4

Thank you very much!

You're welcome

We had the same issue and the edit and save did the trick.

Though we couldn't update the default issue type scheme, because we have so many issue types and the request URI is too long when we try to save it.

We are not using the default issue type scheme, so it's not a big deal, but this way it shows the "old" name. And AFAIK there is no way to remove the issue types from the default scheme.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Core

How to manage many similar workflows?

I have multiple projects that use variations of the same base workflow. The variations depend on the requirements of the project or issue type. The variations mostly come in the form of new statuses ...

2,736 views 11 5
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you